summaryrefslogtreecommitdiffstats
path: root/meta/recipes-bsp/v86d/v86d_0.1.10.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-bsp/v86d/v86d_0.1.10.bb')
-rw-r--r--meta/recipes-bsp/v86d/v86d_0.1.10.bb36
1 files changed, 0 insertions, 36 deletions
diff --git a/meta/recipes-bsp/v86d/v86d_0.1.10.bb b/meta/recipes-bsp/v86d/v86d_0.1.10.bb
index eab466d30d..579a0a27eb 100644
--- a/meta/recipes-bsp/v86d/v86d_0.1.10.bb
+++ b/meta/recipes-bsp/v86d/v86d_0.1.10.bb
@@ -11,8 +11,6 @@ PR = "r2"
11 11
12SRC_URI = "http://distfiles.gentoo.org/distfiles/${BP}.tar.bz2 \ 12SRC_URI = "http://distfiles.gentoo.org/distfiles/${BP}.tar.bz2 \
13 file://Update-x86emu-from-X.org.patch \ 13 file://Update-x86emu-from-X.org.patch \
14 file://fbsetup \
15 file://uvesafb.conf \
16 file://ar-from-env.patch \ 14 file://ar-from-env.patch \
17 file://aarch64-host.patch \ 15 file://aarch64-host.patch \
18" 16"
@@ -23,9 +21,6 @@ SRC_URI[sha256sum] = "634964ae18ef68c8493add2ce150e3b4502badeb0d9194b4bd81241d25
23PACKAGE_ARCH = "${MACHINE_ARCH}" 21PACKAGE_ARCH = "${MACHINE_ARCH}"
24COMPATIBLE_HOST = '(i.86|x86_64).*-linux' 22COMPATIBLE_HOST = '(i.86|x86_64).*-linux'
25 23
26INITSCRIPT_NAME = "fbsetup"
27INITSCRIPT_PARAMS = "start 0 S ."
28
29do_configure () { 24do_configure () {
30 ./configure --with-x86emu 25 ./configure --with-x86emu
31} 26}
@@ -37,35 +32,4 @@ do_compile () {
37do_install () { 32do_install () {
38 install -d ${D}${base_sbindir} 33 install -d ${D}${base_sbindir}
39 install v86d ${D}${base_sbindir}/ 34 install v86d ${D}${base_sbindir}/
40
41 # Only install fbsetup script if 'sysvinit' is in DISTRO_FEATURES
42 if ${@bb.utils.contains('DISTRO_FEATURES','sysvinit','true','false',d)}; then
43 install -d ${D}${sysconfdir}/init.d/
44 install -m 0755 ${WORKDIR}/fbsetup ${D}${sysconfdir}/init.d/fbsetup
45 fi
46
47 # Install systemd related configuration file
48 if ${@bb.utils.contains('DISTRO_FEATURES','systemd','true','false',d)}; then
49 install -d ${D}${sysconfdir}/modules-load.d
50 install -m 0644 ${WORKDIR}/uvesafb.conf ${D}${sysconfdir}/modules-load.d
51 fi
52}
53
54# As the recipe doesn't inherit systemd.bbclass, we need to set this variable
55# manually to avoid unnecessary postinst/preinst generated.
56python __anonymous() {
57 if not bb.utils.contains('DISTRO_FEATURES', 'sysvinit', True, False, d):
58 d.setVar("INHIBIT_UPDATERCD_BBCLASS", "1")
59}
60
61inherit update-rc.d
62
63PACKAGE_WRITE_DEPS_append = " ${@bb.utils.contains('DISTRO_FEATURES','systemd','systemd-systemctl-native','',d)}"
64pkg_postinst_${PN} () {
65 if ${@bb.utils.contains('DISTRO_FEATURES','systemd sysvinit','true','false',d)}; then
66 if [ -n "$D" ]; then
67 OPTS="--root=$D"
68 fi
69 systemctl $OPTS mask fbsetup.service
70 fi
71} 35}