summaryrefslogtreecommitdiffstats
path: root/meta/recipes-bsp/v86d/v86d_0.1.10.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-bsp/v86d/v86d_0.1.10.bb')
-rw-r--r--meta/recipes-bsp/v86d/v86d_0.1.10.bb41
1 files changed, 41 insertions, 0 deletions
diff --git a/meta/recipes-bsp/v86d/v86d_0.1.10.bb b/meta/recipes-bsp/v86d/v86d_0.1.10.bb
new file mode 100644
index 0000000000..a8f1d08247
--- /dev/null
+++ b/meta/recipes-bsp/v86d/v86d_0.1.10.bb
@@ -0,0 +1,41 @@
1SUMMARY = "User support binary for the uvesafb kernel module"
2HOMEPAGE = "http://dev.gentoo.org/~spock/projects/uvesafb/"
3
4# the copyright info is at the bottom of README, expect break
5LICENSE = "GPLv2"
6LIC_FILES_CHKSUM = "file://README;md5=94ac1971e4f2309dc322d598e7b1f7dd"
7
8DEPENDS = "virtual/kernel"
9RRECOMMENDS_${PN} = "kernel-module-uvesafb"
10PR = "r1"
11
12SRC_URI = "http://distfiles.gentoo.org/distfiles/${BP}.tar.bz2 \
13 file://fbsetup \
14 file://ar-from-env.patch"
15
16SRC_URI[md5sum] = "51c792ba7b874ad8c43f0d3da4cfabe0"
17SRC_URI[sha256sum] = "634964ae18ef68c8493add2ce150e3b4502badeb0d9194b4bd81241d25e6735c"
18
19PACKAGE_ARCH = "${MACHINE_ARCH}"
20COMPATIBLE_HOST = '(i.86|x86_64).*-linux'
21
22INITSCRIPT_NAME = "fbsetup"
23INITSCRIPT_PARAMS = "start 0 S ."
24
25do_configure () {
26 ./configure --with-x86emu
27}
28
29do_compile () {
30 KDIR="${STAGING_DIR_HOST}/usr" make
31}
32
33do_install () {
34 install -d ${D}${base_sbindir}
35 install v86d ${D}${base_sbindir}/
36
37 install -d ${D}${sysconfdir}/init.d/
38 install -m 0755 ${WORKDIR}/fbsetup ${D}${sysconfdir}/init.d/fbsetup
39}
40
41inherit update-rc.d