summaryrefslogtreecommitdiffstats
path: root/meta/recipes-bsp/uboot/u-boot-mkimage_2009.08.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-bsp/uboot/u-boot-mkimage_2009.08.bb')
-rw-r--r--meta/recipes-bsp/uboot/u-boot-mkimage_2009.08.bb25
1 files changed, 25 insertions, 0 deletions
diff --git a/meta/recipes-bsp/uboot/u-boot-mkimage_2009.08.bb b/meta/recipes-bsp/uboot/u-boot-mkimage_2009.08.bb
new file mode 100644
index 0000000000..bf07198beb
--- /dev/null
+++ b/meta/recipes-bsp/uboot/u-boot-mkimage_2009.08.bb
@@ -0,0 +1,25 @@
1DESCRIPTION = "U-boot bootloader mkimage tool"
2LICENSE = "GPL"
3SECTION = "bootloader"
4
5PR = "r1"
6
7SRC_URI = "ftp://ftp.denx.de/pub/u-boot/u-boot-${PV}.tar.bz2"
8
9S = "${WORKDIR}/u-boot-${PV}"
10
11EXTRA_OEMAKE = "CROSS_COMPILE=${TARGET_PREFIX}"
12
13BBCLASSEXTEND = "native nativesdk"
14
15do_compile () {
16 oe_runmake smdk2410_config
17 oe_runmake tools
18}
19
20do_install () {
21 install -d ${D}${bindir}
22 install -m 0755 tools/mkimage ${D}${bindir}/uboot-mkimage
23 ln -sf uboot-mkimage ${D}${bindir}/mkimage
24}
25