summaryrefslogtreecommitdiffstats
path: root/meta/recipes-bsp/uboot/u-boot-mkimage-native_1.3.2.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-bsp/uboot/u-boot-mkimage-native_1.3.2.bb')
-rw-r--r--meta/recipes-bsp/uboot/u-boot-mkimage-native_1.3.2.bb23
1 files changed, 23 insertions, 0 deletions
diff --git a/meta/recipes-bsp/uboot/u-boot-mkimage-native_1.3.2.bb b/meta/recipes-bsp/uboot/u-boot-mkimage-native_1.3.2.bb
new file mode 100644
index 0000000000..fcba0d5662
--- /dev/null
+++ b/meta/recipes-bsp/uboot/u-boot-mkimage-native_1.3.2.bb
@@ -0,0 +1,23 @@
1DESCRIPTION = "U-boot bootloader mkimage tool"
2LICENSE = "GPL"
3SECTION = "bootloader"
4
5SRC_URI = "ftp://ftp.denx.de/pub/u-boot/u-boot-${PV}.tar.bz2 \
6 file://fix-arm920t-eabi.patch;patch=1"
7
8S = "${WORKDIR}/u-boot-${PV}"
9
10inherit native
11
12EXTRA_OEMAKE = "CROSS_COMPILE=${TARGET_PREFIX}"
13
14do_compile () {
15 oe_runmake smdk2410_config
16 oe_runmake tools
17}
18
19do_install () {
20 install -d ${D}${bindir}/
21 install -m 0755 tools/mkimage ${D}${bindir}/uboot-mkimage
22 ln -sf uboot-mkimage ${D}${bindir}/mkimage
23}