diff options
Diffstat (limited to 'meta/recipes-bsp/u-boot/u-boot-tools_2018.11.bb')
-rw-r--r-- | meta/recipes-bsp/u-boot/u-boot-tools_2018.11.bb | 52 |
1 files changed, 52 insertions, 0 deletions
diff --git a/meta/recipes-bsp/u-boot/u-boot-tools_2018.11.bb b/meta/recipes-bsp/u-boot/u-boot-tools_2018.11.bb new file mode 100644 index 0000000000..127c4c15d1 --- /dev/null +++ b/meta/recipes-bsp/u-boot/u-boot-tools_2018.11.bb | |||
@@ -0,0 +1,52 @@ | |||
1 | require u-boot-common_${PV}.inc | ||
2 | |||
3 | SUMMARY = "U-Boot bootloader tools" | ||
4 | DEPENDS += "openssl" | ||
5 | |||
6 | PROVIDES = "${MLPREFIX}u-boot-mkimage ${MLPREFIX}u-boot-mkenvimage" | ||
7 | PROVIDES_class-native = "u-boot-mkimage-native u-boot-mkenvimage-native" | ||
8 | |||
9 | PACKAGES += "${PN}-mkimage ${PN}-mkenvimage" | ||
10 | |||
11 | # Required for backward compatibility with "u-boot-mkimage-xxx.bb" | ||
12 | RPROVIDES_${PN}-mkimage = "u-boot-mkimage" | ||
13 | RREPLACES_${PN}-mkimage = "u-boot-mkimage" | ||
14 | RCONFLICTS_${PN}-mkimage = "u-boot-mkimage" | ||
15 | |||
16 | EXTRA_OEMAKE_class-target = 'CROSS_COMPILE="${TARGET_PREFIX}" CC="${CC} ${CFLAGS} ${LDFLAGS}" HOSTCC="${BUILD_CC} ${BUILD_CFLAGS} ${BUILD_LDFLAGS}" STRIP=true V=1' | ||
17 | EXTRA_OEMAKE_class-native = 'CC="${BUILD_CC} ${BUILD_CFLAGS} ${BUILD_LDFLAGS}" HOSTCC="${BUILD_CC} ${BUILD_CFLAGS} ${BUILD_LDFLAGS}" STRIP=true V=1' | ||
18 | EXTRA_OEMAKE_class-nativesdk = 'CROSS_COMPILE="${HOST_PREFIX}" CC="${CC} ${CFLAGS} ${LDFLAGS}" HOSTCC="${BUILD_CC} ${BUILD_CFLAGS} ${BUILD_LDFLAGS}" STRIP=true V=1' | ||
19 | |||
20 | do_compile () { | ||
21 | oe_runmake sandbox_defconfig | ||
22 | |||
23 | # Disable CONFIG_CMD_LICENSE, license.h is not used by tools and | ||
24 | # generating it requires bin2header tool, which for target build | ||
25 | # is built with target tools and thus cannot be executed on host. | ||
26 | sed -i "s/CONFIG_CMD_LICENSE=.*/# CONFIG_CMD_LICENSE is not set/" .config | ||
27 | |||
28 | oe_runmake cross_tools NO_SDL=1 | ||
29 | } | ||
30 | |||
31 | do_install () { | ||
32 | install -d ${D}${bindir} | ||
33 | |||
34 | # mkimage | ||
35 | install -m 0755 tools/mkimage ${D}${bindir}/uboot-mkimage | ||
36 | ln -sf uboot-mkimage ${D}${bindir}/mkimage | ||
37 | |||
38 | # mkenvimage | ||
39 | install -m 0755 tools/mkenvimage ${D}${bindir}/uboot-mkenvimage | ||
40 | ln -sf uboot-mkenvimage ${D}${bindir}/mkenvimage | ||
41 | } | ||
42 | |||
43 | ALLOW_EMPTY_${PN} = "1" | ||
44 | FILES_${PN} = "" | ||
45 | FILES_${PN}-mkimage = "${bindir}/uboot-mkimage ${bindir}/mkimage" | ||
46 | FILES_${PN}-mkenvimage = "${bindir}/uboot-mkenvimage ${bindir}/mkenvimage" | ||
47 | |||
48 | RDEPENDS_${PN}-mkimage += "dtc" | ||
49 | RDEPENDS_${PN} += "${PN}-mkimage ${PN}-mkenvimage" | ||
50 | RDEPENDS_${PN}_class-native = "" | ||
51 | |||
52 | BBCLASSEXTEND = "native nativesdk" | ||