summaryrefslogtreecommitdiffstats
path: root/meta/recipes-bsp/u-boot/u-boot-mkimage_2016.09.01.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-bsp/u-boot/u-boot-mkimage_2016.09.01.bb')
-rw-r--r--meta/recipes-bsp/u-boot/u-boot-mkimage_2016.09.01.bb19
1 files changed, 19 insertions, 0 deletions
diff --git a/meta/recipes-bsp/u-boot/u-boot-mkimage_2016.09.01.bb b/meta/recipes-bsp/u-boot/u-boot-mkimage_2016.09.01.bb
new file mode 100644
index 0000000000..5025961f91
--- /dev/null
+++ b/meta/recipes-bsp/u-boot/u-boot-mkimage_2016.09.01.bb
@@ -0,0 +1,19 @@
1require u-boot-common_${PV}.inc
2
3SUMMARY = "U-Boot bootloader image creation tool"
4DEPENDS = "openssl"
5
6EXTRA_OEMAKE = 'CROSS_COMPILE="${TARGET_PREFIX}" CC="${CC} ${CFLAGS} ${LDFLAGS}" STRIP=true V=1'
7
8do_compile () {
9 oe_runmake sandbox_defconfig
10 oe_runmake cross_tools NO_SDL=1
11}
12
13do_install () {
14 install -d ${D}${bindir}
15 install -m 0755 tools/mkimage ${D}${bindir}/uboot-mkimage
16 ln -sf uboot-mkimage ${D}${bindir}/mkimage
17}
18
19BBCLASSEXTEND = "native nativesdk"