diff options
Diffstat (limited to 'meta/recipes-bsp/u-boot/u-boot-mkimage_2015.01.bb')
-rw-r--r-- | meta/recipes-bsp/u-boot/u-boot-mkimage_2015.01.bb | 32 |
1 files changed, 32 insertions, 0 deletions
diff --git a/meta/recipes-bsp/u-boot/u-boot-mkimage_2015.01.bb b/meta/recipes-bsp/u-boot/u-boot-mkimage_2015.01.bb new file mode 100644 index 0000000000..57989c785f --- /dev/null +++ b/meta/recipes-bsp/u-boot/u-boot-mkimage_2015.01.bb | |||
@@ -0,0 +1,32 @@ | |||
1 | SUMMARY = "U-Boot bootloader image creation tool" | ||
2 | LICENSE = "GPLv2+" | ||
3 | LIC_FILES_CHKSUM = "file://Licenses/README;md5=c7383a594871c03da76b3707929d2919" | ||
4 | SECTION = "bootloader" | ||
5 | |||
6 | DEPENDS = "openssl" | ||
7 | |||
8 | # This revision corresponds to the tag "v2015.01" | ||
9 | # We use the revision in order to avoid having to fetch it from the | ||
10 | # repo during parse | ||
11 | SRCREV = "92fa7f53f1f3f03296f8ffb14bdf1baefab83368" | ||
12 | |||
13 | PV = "v2015.01+git${SRCPV}" | ||
14 | |||
15 | SRC_URI = "git://git.denx.de/u-boot.git;branch=master;protocol=git" | ||
16 | |||
17 | S = "${WORKDIR}/git" | ||
18 | |||
19 | EXTRA_OEMAKE = 'CROSS_COMPILE="${TARGET_PREFIX}" CC="${CC} ${CFLAGS} ${LDFLAGS}" STRIP=true V=1' | ||
20 | |||
21 | do_compile () { | ||
22 | oe_runmake sandbox_defconfig | ||
23 | oe_runmake cross_tools NO_SDL=1 | ||
24 | } | ||
25 | |||
26 | do_install () { | ||
27 | install -d ${D}${bindir} | ||
28 | install -m 0755 tools/mkimage ${D}${bindir}/uboot-mkimage | ||
29 | ln -sf uboot-mkimage ${D}${bindir}/mkimage | ||
30 | } | ||
31 | |||
32 | BBCLASSEXTEND = "native nativesdk" | ||