summaryrefslogtreecommitdiffstats
path: root/meta/recipes-bsp/u-boot/u-boot-mkimage_2013.07.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-bsp/u-boot/u-boot-mkimage_2013.07.bb')
-rw-r--r--meta/recipes-bsp/u-boot/u-boot-mkimage_2013.07.bb32
1 files changed, 32 insertions, 0 deletions
diff --git a/meta/recipes-bsp/u-boot/u-boot-mkimage_2013.07.bb b/meta/recipes-bsp/u-boot/u-boot-mkimage_2013.07.bb
new file mode 100644
index 0000000000..3173b0ac73
--- /dev/null
+++ b/meta/recipes-bsp/u-boot/u-boot-mkimage_2013.07.bb
@@ -0,0 +1,32 @@
1SUMMARY = "U-Boot bootloader image creation tool"
2LICENSE = "GPLv2+"
3LIC_FILES_CHKSUM = "file://COPYING;md5=1707d6db1d42237583f50183a5651ecb"
4SECTION = "bootloader"
5
6# This revision corresponds to the tag "v2013.07"
7# We use the revision in order to avoid having to fetch it from the
8# repo during parse
9SRCREV = "62c175fbb8a0f9a926c88294ea9f7e88eb898f6c"
10
11PV = "v2013.07+git${SRCPV}"
12
13SRC_URI = "git://git.denx.de/u-boot.git;branch=master;protocol=git"
14
15S = "${WORKDIR}/git"
16
17EXTRA_OEMAKE = 'HOSTCC="${CC}" HOSTLD="${LD}" HOSTLDFLAGS="${LDFLAGS}" HOSTSTRIP=true'
18
19do_compile () {
20 # Make sure the recompile is OK
21 rm -f ${B}/tools/.depend
22
23 oe_runmake tools
24}
25
26do_install () {
27 install -d ${D}${bindir}
28 install -m 0755 tools/mkimage ${D}${bindir}/uboot-mkimage
29 ln -sf uboot-mkimage ${D}${bindir}/mkimage
30}
31
32BBCLASSEXTEND = "native nativesdk"