summaryrefslogtreecommitdiffstats
path: root/meta/recipes-bsp/u-boot/u-boot-mkimage_2013.01.01.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-bsp/u-boot/u-boot-mkimage_2013.01.01.bb')
-rw-r--r--meta/recipes-bsp/u-boot/u-boot-mkimage_2013.01.01.bb33
1 files changed, 0 insertions, 33 deletions
diff --git a/meta/recipes-bsp/u-boot/u-boot-mkimage_2013.01.01.bb b/meta/recipes-bsp/u-boot/u-boot-mkimage_2013.01.01.bb
deleted file mode 100644
index dc6e2f6fac..0000000000
--- a/meta/recipes-bsp/u-boot/u-boot-mkimage_2013.01.01.bb
+++ /dev/null
@@ -1,33 +0,0 @@
1DESCRIPTION = "U-boot bootloader mkimage tool"
2LICENSE = "GPLv2+"
3LIC_FILES_CHKSUM = "file://COPYING;md5=1707d6db1d42237583f50183a5651ecb"
4SECTION = "bootloader"
5
6# This is needs to be validated among supported BSP's before we can
7# make it default
8DEFAULT_PREFERENCE = "-1"
9
10# This revision corresponds to the tag "v2013.01.01"
11# We use the revision in order to avoid having to fetch it from the
12# repo during parse
13SRCREV = "e8ae0fa5edd152b2b29c470b88429be4cdcd2c46"
14
15PV = "v2013.01.01+git${SRCPV}"
16
17SRC_URI = "git://git.denx.de/u-boot.git;branch=master"
18
19S = "${WORKDIR}/git"
20
21EXTRA_OEMAKE = 'HOSTCC="${CC}" HOSTLD="${LD}" HOSTLDFLAGS="${LDFLAGS}" HOSTSTRIP=true'
22
23do_compile () {
24 oe_runmake tools
25}
26
27do_install () {
28 install -d ${D}${bindir}
29 install -m 0755 tools/mkimage ${D}${bindir}/uboot-mkimage
30 ln -sf uboot-mkimage ${D}${bindir}/mkimage
31}
32
33BBCLASSEXTEND = "native nativesdk"