summaryrefslogtreecommitdiffstats
path: root/meta/recipes-bsp/u-boot/u-boot-mkimage_2011.06.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-bsp/u-boot/u-boot-mkimage_2011.06.bb')
-rw-r--r--meta/recipes-bsp/u-boot/u-boot-mkimage_2011.06.bb29
1 files changed, 29 insertions, 0 deletions
diff --git a/meta/recipes-bsp/u-boot/u-boot-mkimage_2011.06.bb b/meta/recipes-bsp/u-boot/u-boot-mkimage_2011.06.bb
new file mode 100644
index 0000000000..3ca0c2cfcb
--- /dev/null
+++ b/meta/recipes-bsp/u-boot/u-boot-mkimage_2011.06.bb
@@ -0,0 +1,29 @@
1DESCRIPTION = "U-boot bootloader mkimage tool"
2LICENSE = "GPLv2+"
3LIC_FILES_CHKSUM = "file://COPYING;md5=1707d6db1d42237583f50183a5651ecb \
4 file://README;beginline=1;endline=22;md5=5ba4218ac89af7846802d0348df3fb90"
5SECTION = "bootloader"
6
7PR = "r0"
8
9SRC_URI = "ftp://ftp.denx.de/pub/u-boot/u-boot-${PV}.tar.bz2"
10
11SRC_URI[md5sum] = "0cc5026aad02f218a9b9ac56b301c97a"
12SRC_URI[sha256sum] = "362ddb935885da98cf461eba08f31e3e59d0c4ada6cb2fa15596f43af310ba8b"
13
14S = "${WORKDIR}/u-boot-${PV}"
15
16BBCLASSEXTEND = "native nativesdk"
17
18EXTRA_OEMAKE = 'HOSTCC="${CC}" HOSTLD="${LD}" HOSTLDFLAGS="${LDFLAGS}" HOSTSTRIP=true'
19
20do_compile () {
21 oe_runmake tools
22}
23
24do_install () {
25 install -d ${D}${bindir}
26 install -m 0755 tools/mkimage ${D}${bindir}/uboot-mkimage
27 ln -sf uboot-mkimage ${D}${bindir}/mkimage
28}
29