summaryrefslogtreecommitdiffstats
path: root/meta/recipes-bsp/u-boot/u-boot-mkimage_2011.03.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-bsp/u-boot/u-boot-mkimage_2011.03.bb')
-rw-r--r--meta/recipes-bsp/u-boot/u-boot-mkimage_2011.03.bb31
1 files changed, 31 insertions, 0 deletions
diff --git a/meta/recipes-bsp/u-boot/u-boot-mkimage_2011.03.bb b/meta/recipes-bsp/u-boot/u-boot-mkimage_2011.03.bb
new file mode 100644
index 0000000000..34bae8e3e7
--- /dev/null
+++ b/meta/recipes-bsp/u-boot/u-boot-mkimage_2011.03.bb
@@ -0,0 +1,31 @@
1DESCRIPTION = "U-boot bootloader mkimage tool"
2LICENSE = "GPLv2+"
3LIC_FILES_CHKSUM = "file://COPYING;md5=1707d6db1d42237583f50183a5651ecb \
4 file://README;beginline=1;endline=22;md5=3a00ef51d3fc96e9d6c1bc4708ccd3b5"
5SECTION = "bootloader"
6
7PR = "r1"
8
9SRC_URI = "ftp://ftp.denx.de/pub/u-boot/u-boot-${PV}.tar.bz2 \
10 file://0001-Drop-config.h-include-in-tools-imximage.h.patch \
11 file://0002-config.mk-move-LDSCRIPT-processing-to-the-top-level-.patch"
12
13SRC_URI[md5sum] = "91d02124c94368557d0e9ac05fb8c33f"
14SRC_URI[sha256sum] = "08677f66d8d4ee542f6599f580cdffdf730544e1803f9d3739117d6f6d68083e"
15
16S = "${WORKDIR}/u-boot-${PV}"
17
18BBCLASSEXTEND = "native nativesdk"
19
20EXTRA_OEMAKE = 'HOSTCC="${CC}" HOSTLD="${LD}" HOSTSTRIP=true'
21
22do_compile () {
23 oe_runmake tools
24}
25
26do_install () {
27 install -d ${D}${bindir}
28 install -m 0755 tools/mkimage ${D}${bindir}/uboot-mkimage
29 ln -sf uboot-mkimage ${D}${bindir}/mkimage
30}
31