summaryrefslogtreecommitdiffstats
path: root/meta/recipes-bsp/u-boot/u-boot-fw-utils_2020.01.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-bsp/u-boot/u-boot-fw-utils_2020.01.bb')
-rw-r--r--meta/recipes-bsp/u-boot/u-boot-fw-utils_2020.01.bb36
1 files changed, 36 insertions, 0 deletions
diff --git a/meta/recipes-bsp/u-boot/u-boot-fw-utils_2020.01.bb b/meta/recipes-bsp/u-boot/u-boot-fw-utils_2020.01.bb
new file mode 100644
index 0000000000..04321b7b66
--- /dev/null
+++ b/meta/recipes-bsp/u-boot/u-boot-fw-utils_2020.01.bb
@@ -0,0 +1,36 @@
1require u-boot-common.inc
2
3SUMMARY = "U-Boot bootloader fw_printenv/setenv utilities"
4DEPENDS += "mtd-utils"
5
6SRC_URI += "file://0001-include-env.h-Ensure-ulong-is-defined.patch"
7
8INSANE_SKIP_${PN} = "already-stripped"
9EXTRA_OEMAKE_class-target = 'CROSS_COMPILE=${TARGET_PREFIX} CC="${CC} ${CFLAGS} ${LDFLAGS}" HOSTCC="${BUILD_CC} ${BUILD_CFLAGS} ${BUILD_LDFLAGS}" V=1'
10EXTRA_OEMAKE_class-cross = 'HOSTCC="${CC} ${CFLAGS} ${LDFLAGS}" V=1'
11
12inherit uboot-config
13
14do_compile () {
15 oe_runmake ${UBOOT_MACHINE}
16 oe_runmake envtools
17}
18
19do_install () {
20 install -d ${D}${base_sbindir}
21 install -d ${D}${sysconfdir}
22 install -m 755 ${S}/tools/env/fw_printenv ${D}${base_sbindir}/fw_printenv
23 install -m 755 ${S}/tools/env/fw_printenv ${D}${base_sbindir}/fw_setenv
24 install -m 0644 ${S}/tools/env/fw_env.config ${D}${sysconfdir}/fw_env.config
25}
26
27do_install_class-cross () {
28 install -d ${D}${bindir_cross}
29 install -m 755 ${S}/tools/env/fw_printenv ${D}${bindir_cross}/fw_printenv
30 install -m 755 ${S}/tools/env/fw_printenv ${D}${bindir_cross}/fw_setenv
31}
32
33SYSROOT_DIRS_append_class-cross = " ${bindir_cross}"
34
35PACKAGE_ARCH = "${MACHINE_ARCH}"
36BBCLASSEXTEND = "cross"