diff options
Diffstat (limited to 'meta/recipes-bsp/u-boot/u-boot-fw-utils_2017.07.bb')
-rw-r--r-- | meta/recipes-bsp/u-boot/u-boot-fw-utils_2017.07.bb | 34 |
1 files changed, 34 insertions, 0 deletions
diff --git a/meta/recipes-bsp/u-boot/u-boot-fw-utils_2017.07.bb b/meta/recipes-bsp/u-boot/u-boot-fw-utils_2017.07.bb new file mode 100644 index 0000000000..c2e8f0fb84 --- /dev/null +++ b/meta/recipes-bsp/u-boot/u-boot-fw-utils_2017.07.bb | |||
@@ -0,0 +1,34 @@ | |||
1 | require u-boot-common_${PV}.inc | ||
2 | |||
3 | SUMMARY = "U-Boot bootloader fw_printenv/setenv utilities" | ||
4 | DEPENDS = "mtd-utils" | ||
5 | |||
6 | INSANE_SKIP_${PN} = "already-stripped" | ||
7 | EXTRA_OEMAKE_class-target = 'CROSS_COMPILE=${TARGET_PREFIX} CC="${CC} ${CFLAGS} ${LDFLAGS}" HOSTCC="${BUILD_CC} ${BUILD_CFLAGS} ${BUILD_LDFLAGS}" V=1' | ||
8 | EXTRA_OEMAKE_class-cross = 'ARCH=${TARGET_ARCH} CC="${CC} ${CFLAGS} ${LDFLAGS}" V=1' | ||
9 | |||
10 | inherit uboot-config | ||
11 | |||
12 | do_compile () { | ||
13 | oe_runmake ${UBOOT_MACHINE} | ||
14 | oe_runmake env | ||
15 | } | ||
16 | |||
17 | do_install () { | ||
18 | install -d ${D}${base_sbindir} | ||
19 | install -d ${D}${sysconfdir} | ||
20 | install -m 755 ${S}/tools/env/fw_printenv ${D}${base_sbindir}/fw_printenv | ||
21 | install -m 755 ${S}/tools/env/fw_printenv ${D}${base_sbindir}/fw_setenv | ||
22 | install -m 0644 ${S}/tools/env/fw_env.config ${D}${sysconfdir}/fw_env.config | ||
23 | } | ||
24 | |||
25 | do_install_class-cross () { | ||
26 | install -d ${D}${bindir_cross} | ||
27 | install -m 755 ${S}/tools/env/fw_printenv ${D}${bindir_cross}/fw_printenv | ||
28 | install -m 755 ${S}/tools/env/fw_printenv ${D}${bindir_cross}/fw_setenv | ||
29 | } | ||
30 | |||
31 | SYSROOT_DIRS_append_class-cross = " ${bindir_cross}" | ||
32 | |||
33 | PACKAGE_ARCH = "${MACHINE_ARCH}" | ||
34 | BBCLASSEXTEND = "cross" | ||