summaryrefslogtreecommitdiffstats
path: root/meta/recipes-bsp/u-boot/u-boot-fw-utils_2015.01.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-bsp/u-boot/u-boot-fw-utils_2015.01.bb')
-rw-r--r--meta/recipes-bsp/u-boot/u-boot-fw-utils_2015.01.bb50
1 files changed, 50 insertions, 0 deletions
diff --git a/meta/recipes-bsp/u-boot/u-boot-fw-utils_2015.01.bb b/meta/recipes-bsp/u-boot/u-boot-fw-utils_2015.01.bb
new file mode 100644
index 0000000000..2b0550cb37
--- /dev/null
+++ b/meta/recipes-bsp/u-boot/u-boot-fw-utils_2015.01.bb
@@ -0,0 +1,50 @@
1SUMMARY = "U-Boot bootloader fw_printenv/setenv utilities"
2LICENSE = "GPLv2+"
3LIC_FILES_CHKSUM = "file://Licenses/README;md5=c7383a594871c03da76b3707929d2919"
4SECTION = "bootloader"
5DEPENDS = "mtd-utils"
6
7# This revision corresponds to the tag "v2015.01"
8# We use the revision in order to avoid having to fetch it from the
9# repo during parse
10SRCREV = "92fa7f53f1f3f03296f8ffb14bdf1baefab83368"
11
12PV = "v2015.01+git${SRCPV}"
13
14SRC_URI = "git://git.denx.de/u-boot.git;branch=master;protocol=git \
15 file://0001-tools-env-fix-build-error.patch"
16
17S = "${WORKDIR}/git"
18
19INSANE_SKIP_${PN} = "already-stripped"
20EXTRA_OEMAKE_class-target = 'CROSS_COMPILE=${TARGET_PREFIX} CC="${CC} ${CFLAGS} ${LDFLAGS}" V=1'
21EXTRA_OEMAKE_class-cross = 'ARCH=${TARGET_ARCH} CC="${CC} ${CFLAGS} ${LDFLAGS}" V=1'
22
23inherit uboot-config
24
25do_compile () {
26 oe_runmake ${UBOOT_MACHINE}
27 oe_runmake env
28}
29
30do_install () {
31 install -d ${D}${base_sbindir}
32 install -d ${D}${sysconfdir}
33 install -m 755 ${S}/tools/env/fw_printenv ${D}${base_sbindir}/fw_printenv
34 install -m 755 ${S}/tools/env/fw_printenv ${D}${base_sbindir}/fw_setenv
35 install -m 0644 ${S}/tools/env/fw_env.config ${D}${sysconfdir}/fw_env.config
36}
37
38do_install_class-cross () {
39 install -d ${D}${bindir_cross}
40 install -m 755 ${S}/tools/env/fw_printenv ${D}${bindir_cross}/fw_printenv
41 install -m 755 ${S}/tools/env/fw_printenv ${D}${bindir_cross}/fw_setenv
42}
43
44SYSROOT_PREPROCESS_FUNCS_class-cross = "uboot_fw_utils_cross"
45uboot_fw_utils_cross() {
46 sysroot_stage_dir ${D}${bindir_cross} ${SYSROOT_DESTDIR}${bindir_cross}
47}
48
49PACKAGE_ARCH = "${MACHINE_ARCH}"
50BBCLASSEXTEND = "cross"