summaryrefslogtreecommitdiffstats
path: root/meta/recipes-bsp/u-boot/u-boot-fw-utils_2014.07.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-bsp/u-boot/u-boot-fw-utils_2014.07.bb')
-rw-r--r--meta/recipes-bsp/u-boot/u-boot-fw-utils_2014.07.bb35
1 files changed, 35 insertions, 0 deletions
diff --git a/meta/recipes-bsp/u-boot/u-boot-fw-utils_2014.07.bb b/meta/recipes-bsp/u-boot/u-boot-fw-utils_2014.07.bb
new file mode 100644
index 0000000000..a626c9599a
--- /dev/null
+++ b/meta/recipes-bsp/u-boot/u-boot-fw-utils_2014.07.bb
@@ -0,0 +1,35 @@
1SUMMARY = "U-Boot bootloader fw_printenv/setenv utilities"
2LICENSE = "GPLv2+"
3LIC_FILES_CHKSUM = "file://Licenses/README;md5=025bf9f768cbcb1a165dbe1a110babfb"
4SECTION = "bootloader"
5DEPENDS = "mtd-utils"
6
7# This revision corresponds to the tag "v2014.07"
8# We use the revision in order to avoid having to fetch it from the
9# repo during parse
10SRCREV = "524123a70761110c5cf3ccc5f52f6d4da071b959"
11
12PV = "v2014.07+git${SRCPV}"
13
14SRC_URI = "git://git.denx.de/u-boot.git;branch=master;protocol=git"
15
16S = "${WORKDIR}/git"
17
18INSANE_SKIP_${PN} = "already-stripped"
19
20inherit uboot-config
21
22do_compile () {
23 oe_runmake ${UBOOT_MACHINE}
24 oe_runmake env
25}
26
27do_install () {
28 install -d ${D}${base_sbindir}
29 install -d ${D}${sysconfdir}
30 install -m 755 ${S}/tools/env/fw_printenv ${D}${base_sbindir}/fw_printenv
31 install -m 755 ${S}/tools/env/fw_printenv ${D}${base_sbindir}/fw_setenv
32 install -m 0644 ${S}/tools/env/fw_env.config ${D}${sysconfdir}/fw_env.config
33}
34
35PACKAGE_ARCH = "${MACHINE_ARCH}"