summaryrefslogtreecommitdiffstats
path: root/meta/recipes-bsp/u-boot/u-boot-fw-utils_2013.07.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-bsp/u-boot/u-boot-fw-utils_2013.07.bb')
-rw-r--r--meta/recipes-bsp/u-boot/u-boot-fw-utils_2013.07.bb33
1 files changed, 33 insertions, 0 deletions
diff --git a/meta/recipes-bsp/u-boot/u-boot-fw-utils_2013.07.bb b/meta/recipes-bsp/u-boot/u-boot-fw-utils_2013.07.bb
new file mode 100644
index 0000000000..be543431b3
--- /dev/null
+++ b/meta/recipes-bsp/u-boot/u-boot-fw-utils_2013.07.bb
@@ -0,0 +1,33 @@
1DESCRIPTION = "U-boot bootloader fw_printenv/setenv utils"
2LICENSE = "GPLv2+"
3LIC_FILES_CHKSUM = "file://COPYING;md5=1707d6db1d42237583f50183a5651ecb"
4SECTION = "bootloader"
5DEPENDS = "mtd-utils"
6
7# This revision corresponds to the tag "v2013.07"
8# We use the revision in order to avoid having to fetch it from the
9# repo during parse
10SRCREV = "62c175fbb8a0f9a926c88294ea9f7e88eb898f6c"
11
12PV = "v2013.07+git${SRCPV}"
13
14SRC_URI = "git://git.denx.de/u-boot.git;branch=master;protocol=git"
15
16S = "${WORKDIR}/git"
17
18EXTRA_OEMAKE = 'HOSTCC="${CC}" HOSTSTRIP="true"'
19
20inherit uboot-config
21
22do_compile () {
23 oe_runmake ${UBOOT_MACHINE}
24 oe_runmake env
25}
26
27do_install () {
28 install -d ${D}${base_sbindir}
29 install -m 755 ${S}/tools/env/fw_printenv ${D}${base_sbindir}/fw_printenv
30 install -m 755 ${S}/tools/env/fw_printenv ${D}${base_sbindir}/fw_setenv
31}
32
33PACKAGE_ARCH = "${MACHINE_ARCH}"