summaryrefslogtreecommitdiffstats
path: root/meta/recipes-bsp/u-boot/u-boot-fw-utils-cross_2014.07.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-bsp/u-boot/u-boot-fw-utils-cross_2014.07.bb')
-rw-r--r--meta/recipes-bsp/u-boot/u-boot-fw-utils-cross_2014.07.bb38
1 files changed, 0 insertions, 38 deletions
diff --git a/meta/recipes-bsp/u-boot/u-boot-fw-utils-cross_2014.07.bb b/meta/recipes-bsp/u-boot/u-boot-fw-utils-cross_2014.07.bb
deleted file mode 100644
index d1f1f9a38b..0000000000
--- a/meta/recipes-bsp/u-boot/u-boot-fw-utils-cross_2014.07.bb
+++ /dev/null
@@ -1,38 +0,0 @@
1SUMMARY = "U-Boot bootloader fw_printenv/setenv utilities"
2LICENSE = "GPLv2+"
3LIC_FILES_CHKSUM = "file://Licenses/README;md5=025bf9f768cbcb1a165dbe1a110babfb"
4SECTION = "bootloader"
5DEPENDS = "mtd-utils"
6
7# This revision corresponds to the tag "v2014.07"
8# We use the revision in order to avoid having to fetch it from the
9# repo during parse
10SRCREV = "524123a70761110c5cf3ccc5f52f6d4da071b959"
11
12PV = "v2014.07+git${SRCPV}"
13
14SRC_URI = "git://git.denx.de/u-boot.git;branch=master;protocol=git"
15
16S = "${WORKDIR}/git"
17
18inherit uboot-config cross
19
20EXTRA_OEMAKE = 'CROSS_COMPILE=${TARGET_PREFIX} CC="${TARGET_PREFIX}gcc ${TARGET_CC_ARCH} ${TOOLCHAIN_OPTIONS}"'
21
22do_compile () {
23 oe_runmake ${UBOOT_MACHINE}
24 oe_runmake env
25}
26
27do_install () {
28 install -d ${D}${bindir_cross}
29 install -m 755 ${S}/tools/env/fw_printenv ${D}${bindir_cross}/fw_printenv
30 install -m 755 ${S}/tools/env/fw_printenv ${D}${bindir_cross}/fw_setenv
31}
32
33SYSROOT_PREPROCESS_FUNCS = "uboot_fw_utils_cross"
34uboot_fw_utils_cross() {
35 sysroot_stage_dir ${D}${bindir_cross} ${SYSROOT_DESTDIR}${bindir_cross}
36}
37
38PACKAGE_ARCH = "${MACHINE_ARCH}"