summaryrefslogtreecommitdiffstats
path: root/meta/recipes-bsp/u-boot/u-boot-fw-utils-cross_2013.07.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-bsp/u-boot/u-boot-fw-utils-cross_2013.07.bb')
-rw-r--r--meta/recipes-bsp/u-boot/u-boot-fw-utils-cross_2013.07.bb12
1 files changed, 6 insertions, 6 deletions
diff --git a/meta/recipes-bsp/u-boot/u-boot-fw-utils-cross_2013.07.bb b/meta/recipes-bsp/u-boot/u-boot-fw-utils-cross_2013.07.bb
index e6163972dc..d686b33621 100644
--- a/meta/recipes-bsp/u-boot/u-boot-fw-utils-cross_2013.07.bb
+++ b/meta/recipes-bsp/u-boot/u-boot-fw-utils-cross_2013.07.bb
@@ -20,19 +20,19 @@ inherit uboot-config cross
20EXTRA_OEMAKE = 'CROSS_COMPILE=${TARGET_PREFIX} CC="${TARGET_PREFIX}gcc ${TOOLCHAIN_OPTIONS}"' 20EXTRA_OEMAKE = 'CROSS_COMPILE=${TARGET_PREFIX} CC="${TARGET_PREFIX}gcc ${TOOLCHAIN_OPTIONS}"'
21 21
22do_compile () { 22do_compile () {
23 oe_runmake ${UBOOT_MACHINE} 23 oe_runmake ${UBOOT_MACHINE}
24 oe_runmake env 24 oe_runmake env
25} 25}
26 26
27do_install () { 27do_install () {
28 install -d ${D}${bindir_cross} 28 install -d ${D}${bindir_cross}
29 install -m 755 ${S}/tools/env/fw_printenv ${D}${bindir_cross}/fw_printenv 29 install -m 755 ${S}/tools/env/fw_printenv ${D}${bindir_cross}/fw_printenv
30 install -m 755 ${S}/tools/env/fw_printenv ${D}${bindir_cross}/fw_setenv 30 install -m 755 ${S}/tools/env/fw_printenv ${D}${bindir_cross}/fw_setenv
31} 31}
32 32
33SYSROOT_PREPROCESS_FUNCS = "uboot_fw_utils_cross" 33SYSROOT_PREPROCESS_FUNCS = "uboot_fw_utils_cross"
34uboot_fw_utils_cross() { 34uboot_fw_utils_cross() {
35 sysroot_stage_dir ${D}${bindir_cross} ${SYSROOT_DESTDIR}${bindir_cross} 35 sysroot_stage_dir ${D}${bindir_cross} ${SYSROOT_DESTDIR}${bindir_cross}
36} 36}
37 37
38PACKAGE_ARCH = "${MACHINE_ARCH}" 38PACKAGE_ARCH = "${MACHINE_ARCH}"