summaryrefslogtreecommitdiffstats
path: root/meta/recipes-bsp/u-boot/libubootenv_0.2.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-bsp/u-boot/libubootenv_0.2.bb')
-rw-r--r--meta/recipes-bsp/u-boot/libubootenv_0.2.bb26
1 files changed, 26 insertions, 0 deletions
diff --git a/meta/recipes-bsp/u-boot/libubootenv_0.2.bb b/meta/recipes-bsp/u-boot/libubootenv_0.2.bb
new file mode 100644
index 0000000000..23230d132e
--- /dev/null
+++ b/meta/recipes-bsp/u-boot/libubootenv_0.2.bb
@@ -0,0 +1,26 @@
1SUMMARY = "U-Boot libraries and tools to access environment"
2DEPENDS += "mtd-utils"
3
4DESCRIPTION = "This package contains tools and libraries to read \
5and modify U-Boot environment. \
6It provides a hardware-independent replacement for fw_printenv/setenv utilities \
7provided by U-Boot"
8
9HOMEPAGE = "https://github.com/sbabic/libubootenv"
10LICENSE = "LGPL-2.1"
11LIC_FILES_CHKSUM = "file://Licenses/lgpl-2.1.txt;md5=4fbd65380cdd255951079008b364516c"
12SECTION = "libs"
13
14SRC_URI = "git://github.com/sbabic/libubootenv;protocol=https"
15SRCREV = "bf6ff631c0e38cede67268ceb8bf1383b5f8848e"
16
17S = "${WORKDIR}/git"
18
19inherit cmake
20
21EXTRA_OECMAKE = "-DCMAKE_BUILD_TYPE=Release"
22
23PROVIDES += "u-boot-fw-utils"
24RPROVIDES_${PN} += "u-boot-fw-utils"
25
26BBCLASSEXTEND = "native"