summaryrefslogtreecommitdiffstats
path: root/meta/recipes-bsp/systemd-boot/systemd-boot_232.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-bsp/systemd-boot/systemd-boot_232.bb')
-rw-r--r--meta/recipes-bsp/systemd-boot/systemd-boot_232.bb39
1 files changed, 0 insertions, 39 deletions
diff --git a/meta/recipes-bsp/systemd-boot/systemd-boot_232.bb b/meta/recipes-bsp/systemd-boot/systemd-boot_232.bb
deleted file mode 100644
index 0471ce246b..0000000000
--- a/meta/recipes-bsp/systemd-boot/systemd-boot_232.bb
+++ /dev/null
@@ -1,39 +0,0 @@
1require recipes-core/systemd/systemd.inc
2
3DEPENDS = "intltool-native libcap util-linux gnu-efi gperf-native"
4
5SRC_URI += "file://0001-use-lnr-wrapper-instead-of-looking-for-relative-opti.patch"
6
7inherit autotools pkgconfig gettext
8inherit deploy
9
10# Man pages are packaged through the main systemd recipe
11EXTRA_OECONF = " --enable-gnuefi \
12 --with-efi-includedir=${STAGING_INCDIR} \
13 --with-efi-ldsdir=${STAGING_LIBDIR} \
14 --with-efi-libdir=${STAGING_LIBDIR} \
15 --disable-manpages \
16 "
17
18# Imported from the old gummiboot recipe
19TUNE_CCARGS_remove = "-mfpmath=sse"
20COMPATIBLE_HOST = "(x86_64.*|i.86.*)-linux"
21
22do_compile() {
23 SYSTEMD_BOOT_EFI_ARCH="ia32"
24 if [ "${TARGET_ARCH}" = "x86_64" ]; then
25 SYSTEMD_BOOT_EFI_ARCH="x64"
26 fi
27
28 oe_runmake systemd-boot${SYSTEMD_BOOT_EFI_ARCH}.efi
29}
30
31do_install() {
32 # Bypass systemd installation with a NOP
33 :
34}
35
36do_deploy () {
37 install ${B}/systemd-boot*.efi ${DEPLOYDIR}
38}
39addtask deploy before do_build after do_compile