summaryrefslogtreecommitdiffstats
path: root/meta/recipes-bsp/setserial/setserial_2.17.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-bsp/setserial/setserial_2.17.bb')
-rw-r--r--meta/recipes-bsp/setserial/setserial_2.17.bb26
1 files changed, 26 insertions, 0 deletions
diff --git a/meta/recipes-bsp/setserial/setserial_2.17.bb b/meta/recipes-bsp/setserial/setserial_2.17.bb
new file mode 100644
index 0000000000..65d6068d15
--- /dev/null
+++ b/meta/recipes-bsp/setserial/setserial_2.17.bb
@@ -0,0 +1,26 @@
1SUMMARY = "Controls the configuration of serial ports"
2DESCRIPTION = "setserial is a program designed to set and/or report the configuration information associated with a serial port"
3HOMEPAGE = "http://setserial.sourceforge.net"
4AUTHOR = "Theodore Ts'o <tytso@mit.edu>"
5SECTION = "console/utils"
6
7LICENSE = "GPLv2.0"
8LIC_FILES_CHKSUM = "file://version.h;beginline=1;endline=6;md5=2e7c59cb9e57e356ae81f50f4e4dfd99"
9PR = "r3"
10
11inherit autotools-brokensep
12
13SRC_URI = "${SOURCEFORGE_MIRROR}/setserial/${BPN}-${PV}.tar.gz \
14 file://add_stdlib.patch \
15 "
16
17SRC_URI[md5sum] = "c4867d72c41564318e0107745eb7a0f2"
18SRC_URI[sha256sum] = "7e4487d320ac31558563424189435d396ddf77953bb23111a17a3d1487b5794a"
19
20do_install() {
21 install -d ${D}${bindir}
22 install -d ${D}${mandir}/man8
23
24 install -m 0755 ${S}/setserial ${D}${bindir}
25 install -m 0644 ${S}/setserial.8 ${D}${mandir}/man8
26}