diff options
Diffstat (limited to 'meta/recipes-bsp/qemu-config/qemu-config.bb')
-rw-r--r-- | meta/recipes-bsp/qemu-config/qemu-config.bb | 36 |
1 files changed, 36 insertions, 0 deletions
diff --git a/meta/recipes-bsp/qemu-config/qemu-config.bb b/meta/recipes-bsp/qemu-config/qemu-config.bb new file mode 100644 index 0000000000..fc59320282 --- /dev/null +++ b/meta/recipes-bsp/qemu-config/qemu-config.bb | |||
@@ -0,0 +1,36 @@ | |||
1 | DESCRIPTION = "Adds scripts to use distcc on the host system under qemu" | ||
2 | LICENSE = "GPL" | ||
3 | RDEPENDS = "distcc task-poky-nfs-server oprofileui-server rsync bash" | ||
4 | PR = "r17" | ||
5 | |||
6 | SRC_URI = "file://distcc.sh \ | ||
7 | file://anjuta-remote-run \ | ||
8 | file://exports \ | ||
9 | file://shutdown.desktop \ | ||
10 | file://qemu-autostart" | ||
11 | |||
12 | S = "${WORKDIR}" | ||
13 | |||
14 | COMPATIBLE_MACHINE = "(qemuarm|qemux86)" | ||
15 | PACKAGE_ARCH = "all" | ||
16 | |||
17 | do_install() { | ||
18 | install -d ${D}${sysconfdir}/profile.d | ||
19 | |||
20 | install -m 0755 distcc.sh ${D}${sysconfdir}/profile.d/ | ||
21 | install -m 0644 exports ${D}${sysconfdir}/ | ||
22 | |||
23 | install -d ${D}${bindir} | ||
24 | install -m 0755 anjuta-remote-run ${D}${bindir}/ | ||
25 | |||
26 | install -d ${D}${datadir}/applications | ||
27 | install -m 0644 shutdown.desktop ${D}${datadir}/applications/ | ||
28 | |||
29 | install -d ${D}/etc/init.d | ||
30 | install qemu-autostart ${D}/etc/init.d/ | ||
31 | } | ||
32 | |||
33 | inherit update-rc.d | ||
34 | |||
35 | INITSCRIPT_NAME = "qemu-autostart" | ||
36 | INITSCRIPT_PARAMS = "start 999 5 2 . stop 20 0 1 6 ." | ||