summaryrefslogtreecommitdiffstats
path: root/meta/recipes-bsp/qemu-config/qemu-config.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-bsp/qemu-config/qemu-config.bb')
-rw-r--r--meta/recipes-bsp/qemu-config/qemu-config.bb36
1 files changed, 36 insertions, 0 deletions
diff --git a/meta/recipes-bsp/qemu-config/qemu-config.bb b/meta/recipes-bsp/qemu-config/qemu-config.bb
new file mode 100644
index 0000000000..fc59320282
--- /dev/null
+++ b/meta/recipes-bsp/qemu-config/qemu-config.bb
@@ -0,0 +1,36 @@
1DESCRIPTION = "Adds scripts to use distcc on the host system under qemu"
2LICENSE = "GPL"
3RDEPENDS = "distcc task-poky-nfs-server oprofileui-server rsync bash"
4PR = "r17"
5
6SRC_URI = "file://distcc.sh \
7 file://anjuta-remote-run \
8 file://exports \
9 file://shutdown.desktop \
10 file://qemu-autostart"
11
12S = "${WORKDIR}"
13
14COMPATIBLE_MACHINE = "(qemuarm|qemux86)"
15PACKAGE_ARCH = "all"
16
17do_install() {
18 install -d ${D}${sysconfdir}/profile.d
19
20 install -m 0755 distcc.sh ${D}${sysconfdir}/profile.d/
21 install -m 0644 exports ${D}${sysconfdir}/
22
23 install -d ${D}${bindir}
24 install -m 0755 anjuta-remote-run ${D}${bindir}/
25
26 install -d ${D}${datadir}/applications
27 install -m 0644 shutdown.desktop ${D}${datadir}/applications/
28
29 install -d ${D}/etc/init.d
30 install qemu-autostart ${D}/etc/init.d/
31}
32
33inherit update-rc.d
34
35INITSCRIPT_NAME = "qemu-autostart"
36INITSCRIPT_PARAMS = "start 999 5 2 . stop 20 0 1 6 ."