summaryrefslogtreecommitdiffstats
path: root/meta/recipes-bsp/qemu-config/qemu-config.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-bsp/qemu-config/qemu-config.bb')
-rw-r--r--meta/recipes-bsp/qemu-config/qemu-config.bb6
1 files changed, 1 insertions, 5 deletions
diff --git a/meta/recipes-bsp/qemu-config/qemu-config.bb b/meta/recipes-bsp/qemu-config/qemu-config.bb
index ac3e7f3dad..6775af34e3 100644
--- a/meta/recipes-bsp/qemu-config/qemu-config.bb
+++ b/meta/recipes-bsp/qemu-config/qemu-config.bb
@@ -10,7 +10,6 @@ COMPATIBLE_MACHINE = "(qemuarm|qemux86|qemumips|qemuppc)"
10PR = "r25" 10PR = "r25"
11 11
12SRC_URI = "file://distcc.sh \ 12SRC_URI = "file://distcc.sh \
13 file://anjuta-remote-run \
14 file://exports \ 13 file://exports \
15 file://shutdown.desktop \ 14 file://shutdown.desktop \
16 file://qemu-autostart" 15 file://qemu-autostart"
@@ -23,9 +22,6 @@ do_install() {
23 install -m 0755 distcc.sh ${D}${sysconfdir}/profile.d/ 22 install -m 0755 distcc.sh ${D}${sysconfdir}/profile.d/
24 install -m 0644 exports ${D}${sysconfdir}/ 23 install -m 0644 exports ${D}${sysconfdir}/
25 24
26 install -d ${D}${bindir}
27 install -m 0755 anjuta-remote-run ${D}${bindir}/
28
29 install -d ${D}${datadir}/applications 25 install -d ${D}${datadir}/applications
30 install -m 0644 shutdown.desktop ${D}${datadir}/applications/ 26 install -m 0644 shutdown.desktop ${D}${datadir}/applications/
31 27
@@ -38,7 +34,7 @@ pkg_postinst_${PN} () {
38 sed -i $D${datadir}/applications/shutdown.desktop -e 's/^Exec=halt/Exec=reboot/' 34 sed -i $D${datadir}/applications/shutdown.desktop -e 's/^Exec=halt/Exec=reboot/'
39} 35}
40 36
41RDEPENDS_${PN} = "distcc ${@base_contains('DISTRO_FEATURES', 'x11', 'dbus-x11', '', d)} packagegroup-core-nfs-server oprofileui-server rsync bash" 37RDEPENDS_${PN} = "distcc packagegroup-core-nfs-server oprofileui-server bash"
42 38
43inherit update-rc.d allarch 39inherit update-rc.d allarch
44 40