diff options
Diffstat (limited to 'meta/recipes-bsp/pciutils/pciutils_3.6.2.bb')
-rw-r--r-- | meta/recipes-bsp/pciutils/pciutils_3.6.2.bb | 60 |
1 files changed, 60 insertions, 0 deletions
diff --git a/meta/recipes-bsp/pciutils/pciutils_3.6.2.bb b/meta/recipes-bsp/pciutils/pciutils_3.6.2.bb new file mode 100644 index 0000000000..413421cd8a --- /dev/null +++ b/meta/recipes-bsp/pciutils/pciutils_3.6.2.bb | |||
@@ -0,0 +1,60 @@ | |||
1 | SUMMARY = "PCI utilities" | ||
2 | DESCRIPTION = 'The PCI Utilities package contains a library for portable access \ | ||
3 | to PCI bus configuration space and several utilities based on this library.' | ||
4 | HOMEPAGE = "http://atrey.karlin.mff.cuni.cz/~mj/pciutils.shtml" | ||
5 | SECTION = "console/utils" | ||
6 | |||
7 | LICENSE = "GPLv2+" | ||
8 | LIC_FILES_CHKSUM = "file://COPYING;md5=751419260aa954499f7abaabaa882bbe" | ||
9 | DEPENDS = "zlib kmod" | ||
10 | |||
11 | SRC_URI = "${KERNELORG_MIRROR}/software/utils/pciutils/pciutils-${PV}.tar.xz \ | ||
12 | file://configure.patch" | ||
13 | |||
14 | SRC_URI[md5sum] = "77963796d1be4f451b83e6da28ba4f82" | ||
15 | SRC_URI[sha256sum] = "db452ec986edefd88af0d222d22f6102f8030a8633fdfe846c3ae4bde9bb93f3" | ||
16 | |||
17 | inherit multilib_header pkgconfig | ||
18 | |||
19 | PACKAGECONFIG ??= "${@bb.utils.contains('DISTRO_FEATURES', 'systemd', 'hwdb', '', d)}" | ||
20 | PACKAGECONFIG[hwdb] = "HWDB=yes,HWDB=no,udev" | ||
21 | |||
22 | PCI_CONF_FLAG = "ZLIB=yes DNS=yes SHARED=yes STRIP= LIBDIR=${libdir}" | ||
23 | |||
24 | # see configure.patch | ||
25 | do_configure () { | ||
26 | ( | ||
27 | cd lib && \ | ||
28 | # PACKAGECONFIG_CONFARGS for this recipe could only possibly contain 'HWDB=yes/no', | ||
29 | # so we put it before ./configure | ||
30 | ${PCI_CONF_FLAG} ${PACKAGECONFIG_CONFARGS} ./configure ${PV} ${datadir} ${TARGET_OS} ${TARGET_ARCH} | ||
31 | ) | ||
32 | } | ||
33 | |||
34 | export PREFIX = "${prefix}" | ||
35 | export SBINDIR = "${sbindir}" | ||
36 | export SHAREDIR = "${datadir}" | ||
37 | export MANDIR = "${mandir}" | ||
38 | |||
39 | EXTRA_OEMAKE = "-e MAKEFLAGS= ${PCI_CONF_FLAG}" | ||
40 | |||
41 | ASNEEDED = "" | ||
42 | |||
43 | # The configure script breaks if the HOST variable is set | ||
44 | HOST[unexport] = "1" | ||
45 | |||
46 | do_install () { | ||
47 | oe_runmake DESTDIR=${D} install install-lib | ||
48 | |||
49 | install -d ${D}${bindir} | ||
50 | ln -s ../sbin/lspci ${D}${bindir}/lspci | ||
51 | |||
52 | oe_multilib_header pci/config.h | ||
53 | } | ||
54 | |||
55 | PACKAGES =+ "${PN}-ids libpci" | ||
56 | FILES_${PN}-ids = "${datadir}/pci.ids*" | ||
57 | FILES_libpci = "${libdir}/libpci.so.*" | ||
58 | SUMMARY_${PN}-ids = "PCI utilities - device ID database" | ||
59 | DESCRIPTION_${PN}-ids = "Package providing the PCI device ID database for pciutils." | ||
60 | RDEPENDS_${PN} += "${PN}-ids" | ||