summaryrefslogtreecommitdiffstats
path: root/meta/recipes-bsp/opensbi/opensbi_1.1.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-bsp/opensbi/opensbi_1.1.bb')
-rw-r--r--meta/recipes-bsp/opensbi/opensbi_1.1.bb47
1 files changed, 47 insertions, 0 deletions
diff --git a/meta/recipes-bsp/opensbi/opensbi_1.1.bb b/meta/recipes-bsp/opensbi/opensbi_1.1.bb
new file mode 100644
index 0000000000..d3a6296533
--- /dev/null
+++ b/meta/recipes-bsp/opensbi/opensbi_1.1.bb
@@ -0,0 +1,47 @@
1SUMMARY = "RISC-V Open Source Supervisor Binary Interface (OpenSBI)"
2DESCRIPTION = "OpenSBI aims to provide an open-source and extensible implementation of the RISC-V SBI specification for a platform specific firmware (M-mode) and a general purpose OS, hypervisor or bootloader (S-mode or HS-mode). OpenSBI implementation can be easily extended by RISC-V platform or System-on-Chip vendors to fit a particular hadware configuration."
3HOMEPAGE = "https://github.com/riscv/opensbi"
4LICENSE = "BSD-2-Clause"
5LIC_FILES_CHKSUM = "file://COPYING.BSD;md5=42dd9555eb177f35150cf9aa240b61e5"
6
7require opensbi-payloads.inc
8
9inherit autotools-brokensep deploy
10
11SRCREV = "4489876e933d8ba0d8bc6c64bae71e295d45faac"
12SRC_URI = "git://github.com/riscv/opensbi.git;branch=master;protocol=https"
13
14S = "${WORKDIR}/git"
15
16EXTRA_OEMAKE += "PLATFORM=${RISCV_SBI_PLAT} I=${D} FW_PIC=n CLANG_TARGET= "
17# If RISCV_SBI_PAYLOAD is set then include it as a payload
18EXTRA_OEMAKE:append = " ${@riscv_get_extra_oemake_image(d)}"
19EXTRA_OEMAKE:append = " ${@riscv_get_extra_oemake_fdt(d)}"
20
21# Required if specifying a custom payload
22do_compile[depends] += "${@riscv_get_do_compile_depends(d)}"
23
24do_install:append() {
25 # In the future these might be required as a dependency for other packages.
26 # At the moment just delete them to avoid warnings
27 rm -r ${D}/include
28 rm -r ${D}/lib*
29 rm -r ${D}/share/opensbi/*/${RISCV_SBI_PLAT}/firmware/payloads
30}
31
32do_deploy () {
33 install -m 755 ${D}/share/opensbi/*/${RISCV_SBI_PLAT}/firmware/fw_payload.* ${DEPLOYDIR}/
34 install -m 755 ${D}/share/opensbi/*/${RISCV_SBI_PLAT}/firmware/fw_jump.* ${DEPLOYDIR}/
35 install -m 755 ${D}/share/opensbi/*/${RISCV_SBI_PLAT}/firmware/fw_dynamic.* ${DEPLOYDIR}/
36}
37
38addtask deploy before do_build after do_install
39
40FILES:${PN} += "/share/opensbi/*/${RISCV_SBI_PLAT}/firmware/fw_jump.*"
41FILES:${PN} += "/share/opensbi/*/${RISCV_SBI_PLAT}/firmware/fw_payload.*"
42FILES:${PN} += "/share/opensbi/*/${RISCV_SBI_PLAT}/firmware/fw_dynamic.*"
43
44COMPATIBLE_HOST = "(riscv64|riscv32).*"
45INHIBIT_PACKAGE_STRIP = "1"
46
47SECURITY_CFLAGS = ""