diff options
Diffstat (limited to 'meta/recipes-bsp/opensbi/opensbi_0.4.bb')
-rw-r--r-- | meta/recipes-bsp/opensbi/opensbi_0.4.bb | 51 |
1 files changed, 51 insertions, 0 deletions
diff --git a/meta/recipes-bsp/opensbi/opensbi_0.4.bb b/meta/recipes-bsp/opensbi/opensbi_0.4.bb new file mode 100644 index 0000000000..139718c72b --- /dev/null +++ b/meta/recipes-bsp/opensbi/opensbi_0.4.bb | |||
@@ -0,0 +1,51 @@ | |||
1 | SUMMARY = "RISC-V Open Source Supervisor Binary Interface (OpenSBI)" | ||
2 | DESCRIPTION = "OpenSBI aims to provide an open-source and extensible implementation of the RISC-V SBI specification for a platform specific firmware (M-mode) and a general purpose OS, hypervisor or bootloader (S-mode or HS-mode). OpenSBI implementation can be easily extended by RISC-V platform or System-on-Chip vendors to fit a particular hadware configuration." | ||
3 | LICENSE = "BSD-2-Clause" | ||
4 | LIC_FILES_CHKSUM = "file://COPYING.BSD;md5=42dd9555eb177f35150cf9aa240b61e5" | ||
5 | DEPENDS += "dtc-native" | ||
6 | |||
7 | require opensbi-payloads.inc | ||
8 | |||
9 | inherit autotools-brokensep | ||
10 | |||
11 | SRCREV = "ce228ee0919deb9957192d723eecc8aaae2697c6" | ||
12 | SRC_URI = "git://github.com/riscv/opensbi.git \ | ||
13 | file://0001-Makefile-Don-t-specify-mabi-or-march.patch \ | ||
14 | " | ||
15 | |||
16 | S = "${WORKDIR}/git" | ||
17 | |||
18 | SRC_URI[md5sum] = "621f38d8205ef5fb185e4055025e73df" | ||
19 | SRC_URI[sha256sum] = "07f18b73abf3b85aabe5bead19a923716c100d30eb58033459f39c3a224be300" | ||
20 | |||
21 | EXTRA_OEMAKE += "PLATFORM=${RISCV_SBI_PLAT} I=${D}" | ||
22 | # If RISCV_SBI_PAYLOAD is set then include it as a payload | ||
23 | EXTRA_OEMAKE_append = " ${@riscv_get_extra_oemake_image(d)} ${@riscv_get_extra_oemake_fdt(d)}" | ||
24 | |||
25 | # Required if specifying a custom payload | ||
26 | do_compile[depends] += "${@riscv_get_do_compile_depends(d)}" | ||
27 | |||
28 | do_install_append() { | ||
29 | # In the future these might be required as a dependency for other packages. | ||
30 | # At the moment just delete them to avoid warnings | ||
31 | rm -r ${D}/include | ||
32 | rm -r ${D}/platform/${RISCV_SBI_PLAT}/lib | ||
33 | rm -r ${D}/platform/${RISCV_SBI_PLAT}/firmware/payloads | ||
34 | } | ||
35 | |||
36 | do_deploy () { | ||
37 | install -d ${DEPLOY_DIR_IMAGE} | ||
38 | install -m 755 ${D}/platform/${RISCV_SBI_PLAT}/firmware/fw_payload.* ${DEPLOY_DIR_IMAGE}/ | ||
39 | install -m 755 ${D}/platform/${RISCV_SBI_PLAT}/firmware/fw_jump.* ${DEPLOY_DIR_IMAGE}/ | ||
40 | install -m 755 ${D}/platform/${RISCV_SBI_PLAT}/firmware/fw_dynamic.* ${DEPLOY_DIR_IMAGE}/ | ||
41 | } | ||
42 | |||
43 | addtask deploy after do_install | ||
44 | |||
45 | FILES_${PN} += "/platform/${RISCV_SBI_PLAT}/firmware/fw_jump.*" | ||
46 | FILES_${PN} += "/platform/${RISCV_SBI_PLAT}/firmware/fw_payload.*" | ||
47 | FILES_${PN} += "/platform/${RISCV_SBI_PLAT}/firmware/fw_dynamic.*" | ||
48 | |||
49 | |||
50 | COMPATIBLE_HOST = "(riscv64|riscv32).*" | ||
51 | INHIBIT_PACKAGE_STRIP = "1" | ||