summaryrefslogtreecommitdiffstats
path: root/meta/recipes-bsp/keymaps/keymaps_1.0.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-bsp/keymaps/keymaps_1.0.bb')
-rw-r--r--meta/recipes-bsp/keymaps/keymaps_1.0.bb20
1 files changed, 1 insertions, 19 deletions
diff --git a/meta/recipes-bsp/keymaps/keymaps_1.0.bb b/meta/recipes-bsp/keymaps/keymaps_1.0.bb
index 7f2211a2b9..4683fa1d3a 100644
--- a/meta/recipes-bsp/keymaps/keymaps_1.0.bb
+++ b/meta/recipes-bsp/keymaps/keymaps_1.0.bb
@@ -5,35 +5,17 @@ RDEPENDS_${PN} = "initscripts console-tools"
5LICENSE = "GPLv2" 5LICENSE = "GPLv2"
6LIC_FILES_CHKSUM = "file://COPYING;md5=751419260aa954499f7abaabaa882bbe" 6LIC_FILES_CHKSUM = "file://COPYING;md5=751419260aa954499f7abaabaa882bbe"
7PACKAGE_ARCH = "${MACHINE_ARCH}" 7PACKAGE_ARCH = "${MACHINE_ARCH}"
8PR = "r18" 8PR = "r19"
9 9
10inherit update-rc.d 10inherit update-rc.d
11 11
12SRC_URI = "file://keymap.sh \ 12SRC_URI = "file://keymap.sh \
13 file://GPLv2.patch" 13 file://GPLv2.patch"
14 14
15SRC_URI_append_c7x0 = " file://keymap-*.map"
16SRC_URI_append_tosa = " file://keymap-*.map"
17SRC_URI_append_akita = " file://keymap-*.map"
18SRC_URI_append_spitz = " file://keymap-*.map"
19SRC_URI_append_collie = " file://keymap-*.map"
20SRC_URI_append_poodle = " file://keymap-*.map"
21SRC_URI_append_jornada6xx = " file://keymap-*.map"
22SRC_URI_append_h2200 = " file://keymap-*.map"
23SRC_URI_append_htcuniversal = " file://keymap-*.map"
24
25INITSCRIPT_NAME = "keymap.sh" 15INITSCRIPT_NAME = "keymap.sh"
26INITSCRIPT_PARAMS = "start 01 S ." 16INITSCRIPT_PARAMS = "start 01 S ."
27 17
28do_install () { 18do_install () {
29 install -d ${D}${sysconfdir}/init.d/ 19 install -d ${D}${sysconfdir}/init.d/
30 install -m 0755 ${WORKDIR}/keymap.sh ${D}${sysconfdir}/init.d/ 20 install -m 0755 ${WORKDIR}/keymap.sh ${D}${sysconfdir}/init.d/
31
32 case ${MACHINE} in
33 c7x0 | tosa | spitz | akita | borzoi | collie | poodle | jornada6xx | h2200 | htcuniversal )
34 install -m 0644 ${WORKDIR}/keymap-*.map ${D}${sysconfdir}
35 ;;
36 *)
37 ;;
38 esac
39} 21}