summaryrefslogtreecommitdiffstats
path: root/meta/recipes-bsp/hostap/hostap-conf_1.0.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-bsp/hostap/hostap-conf_1.0.bb')
-rw-r--r--meta/recipes-bsp/hostap/hostap-conf_1.0.bb29
1 files changed, 29 insertions, 0 deletions
diff --git a/meta/recipes-bsp/hostap/hostap-conf_1.0.bb b/meta/recipes-bsp/hostap/hostap-conf_1.0.bb
new file mode 100644
index 0000000000..ce069662c7
--- /dev/null
+++ b/meta/recipes-bsp/hostap/hostap-conf_1.0.bb
@@ -0,0 +1,29 @@
1DESCRIPTION = "PCMCIA-cs configuration files for wireless LAN cards based on Intersil's Prism2/2.5/3 chipset"
2SECTION = "kernel/modules"
3PRIORITY = "optional"
4LICENSE = "GPL"
5RDEPENDS = "update-modules"
6PACKAGE_ARCH = "all"
7PR = "r10"
8
9SRC_URI = "file://hostap_cs.modalias"
10
11do_compile() {
12}
13
14do_install() {
15 install -d ${D}${sysconfdir}/modutils
16
17 install -m 0644 ${WORKDIR}/hostap_cs.modalias ${D}${sysconfdir}/modutils/hostap_cs.conf
18}
19
20pkg_postinst () {
21 if [ -n "$D" ]; then
22 exit 1
23 fi
24 update-modules || true
25}
26
27pkg_postrm () {
28 update-modules || true
29}