summaryrefslogtreecommitdiffstats
path: root/meta/recipes-bsp/gummiboot/gummiboot_git.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-bsp/gummiboot/gummiboot_git.bb')
-rw-r--r--meta/recipes-bsp/gummiboot/gummiboot_git.bb34
1 files changed, 34 insertions, 0 deletions
diff --git a/meta/recipes-bsp/gummiboot/gummiboot_git.bb b/meta/recipes-bsp/gummiboot/gummiboot_git.bb
new file mode 100644
index 0000000000..7fc908e4fe
--- /dev/null
+++ b/meta/recipes-bsp/gummiboot/gummiboot_git.bb
@@ -0,0 +1,34 @@
1SUMMARY = "Gummiboot is a simple UEFI boot manager which executes configured EFI images."
2HOMEPAGE = "http://freedesktop.org/wiki/Software/gummiboot"
3
4LICENSE = "LGPLv2.1"
5LIC_FILES_CHKSUM = "file://LICENSE;md5=4fbd65380cdd255951079008b364516c"
6
7DEPENDS = "gnu-efi util-linux"
8
9inherit autotools pkgconfig
10inherit deploy
11
12PV = "43+git${SRCPV}"
13SRCREV = "4062c51075ba054d4949c714fe06123f9ad3097d"
14SRC_URI = "git://anongit.freedesktop.org/gummiboot \
15 file://fix-objcopy.patch \
16 "
17
18# Note: Add COMPATIBLE_HOST here is only because it depends on gnu-efi
19# which has set the COMPATIBLE_HOST, the gummiboot itself may work on
20# more hosts.
21COMPATIBLE_HOST = "(x86_64.*|i.86.*)-linux"
22
23S = "${WORKDIR}/git"
24
25EXTRA_OECONF = "--disable-manpages --with-efi-includedir=${STAGING_INCDIR} \
26 --with-efi-ldsdir=${STAGING_LIBDIR} \
27 --with-efi-libdir=${STAGING_LIBDIR}"
28
29EXTRA_OEMAKE += "gummibootlibdir=${libdir}/gummiboot"
30
31do_deploy () {
32 install ${B}/gummiboot*.efi ${DEPLOYDIR}
33}
34addtask deploy before do_build after do_compile