summaryrefslogtreecommitdiffstats
path: root/meta/recipes-bsp/grub/grub_git.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-bsp/grub/grub_git.bb')
-rw-r--r--meta/recipes-bsp/grub/grub_git.bb64
1 files changed, 64 insertions, 0 deletions
diff --git a/meta/recipes-bsp/grub/grub_git.bb b/meta/recipes-bsp/grub/grub_git.bb
new file mode 100644
index 0000000000..2a6392b82e
--- /dev/null
+++ b/meta/recipes-bsp/grub/grub_git.bb
@@ -0,0 +1,64 @@
1SUMMARY = "GRUB2 is the next-generation GRand Unified Bootloader"
2
3DESCRIPTION = "GRUB2 is the next generaion of a GPLed bootloader \
4intended to unify bootloading across x86 operating systems. In \
5addition to loading the Linux kernel, it implements the Multiboot \
6standard, which allows for flexible loading of multiple boot images."
7
8HOMEPAGE = "http://www.gnu.org/software/grub/"
9SECTION = "bootloaders"
10
11LICENSE = "GPLv3"
12LIC_FILES_CHKSUM = "file://COPYING;md5=d32239bcb673463ab874e80d47fae504"
13
14DEPENDS = "autogen-native flex-native bison-native xz freetype"
15
16DEFAULT_PREFERENCE = "-1"
17DEFAULT_PREFERENCE_arm = "1"
18
19PV = "2.00+${SRCPV}"
20SRCREV = "87de66d9d83446ecddb29cfbdf7369102c8e209e"
21SRC_URI = "git://git.savannah.gnu.org/grub.git \
22 file://autogen.sh-exclude-pc.patch \
23 file://grub-2.00-add-oe-kernel.patch \
24 file://0001-Fix-build-with-glibc-2.20.patch \
25 "
26
27S = "${WORKDIR}/git"
28
29COMPATIBLE_HOST = '(x86_64.*|i.86.*|arm.*|aarch64.*)-(linux.*|freebsd.*)'
30
31inherit autotools gettext texinfo
32
33PACKAGECONFIG ??= ""
34PACKAGECONFIG[grub-mount] = "--enable-grub-mount,--disable-grub-mount,fuse"
35PACKAGECONFIG[device-mapper] = "--enable-device-mapper,--disable-device-mapper,lvm2"
36
37# configure.ac has code to set this automagically from the target tuple
38# but the OE freeform one (core2-foo-bar-linux) don't work with that.
39
40GRUBPLATFORM_arm = "uboot"
41GRUBPLATFORM_aarch64 = "efi"
42GRUBPLATFORM ??= "pc"
43
44EXTRA_OECONF = "--with-platform=${GRUBPLATFORM} --disable-grub-mkfont --program-prefix="" \
45 --enable-liblzma=no --enable-device-mapper=no --enable-libzfs=no"
46
47do_configure_prepend() {
48 ( cd ${S}
49 ${S}/autogen.sh )
50}
51
52do_install_append () {
53 install -d ${D}${sysconfdir}/grub.d
54
55}
56
57# debugedit chokes on bare metal binaries
58INHIBIT_PACKAGE_DEBUG_SPLIT = "1"
59
60RDEPENDS_${PN} = "diffutils freetype"
61FILES_${PN}-dbg += "${libdir}/${BPN}/*/.debug"
62
63INSANE_SKIP_${PN} = "arch"
64INSANE_SKIP_${PN}-dbg = "arch"