diff options
Diffstat (limited to 'meta/recipes-bsp/grub/grub_git.bb')
-rw-r--r-- | meta/recipes-bsp/grub/grub_git.bb | 61 |
1 files changed, 61 insertions, 0 deletions
diff --git a/meta/recipes-bsp/grub/grub_git.bb b/meta/recipes-bsp/grub/grub_git.bb new file mode 100644 index 0000000000..ca636f32ce --- /dev/null +++ b/meta/recipes-bsp/grub/grub_git.bb | |||
@@ -0,0 +1,61 @@ | |||
1 | SUMMARY = "GRUB2 is the next-generation GRand Unified Bootloader" | ||
2 | |||
3 | DESCRIPTION = "GRUB2 is the next generaion of a GPLed bootloader \ | ||
4 | intended to unify bootloading across x86 operating systems. In \ | ||
5 | addition to loading the Linux kernel, it implements the Multiboot \ | ||
6 | standard, which allows for flexible loading of multiple boot images." | ||
7 | |||
8 | HOMEPAGE = "http://www.gnu.org/software/grub/" | ||
9 | SECTION = "bootloaders" | ||
10 | |||
11 | LICENSE = "GPLv3" | ||
12 | LIC_FILES_CHKSUM = "file://COPYING;md5=d32239bcb673463ab874e80d47fae504" | ||
13 | |||
14 | DEPENDS = "autogen-native flex-native bison-native xz freetype" | ||
15 | |||
16 | DEFAULT_PREFERENCE = "-1" | ||
17 | DEFAULT_PREFERENCE_arm = "1" | ||
18 | |||
19 | PV = "2.00+${SRCPV}" | ||
20 | SRCREV = "3bc1b2daabb9b07a9c08bca386005d96f07147fe" | ||
21 | SRC_URI = "git://git.savannah.gnu.org/grub.git \ | ||
22 | file://0001-fdt-add-grub_fdt_create_empty_tree-function.patch \ | ||
23 | file://0002-arm64-add-EFI-Linux-loader.patch \ | ||
24 | file://40_custom \ | ||
25 | " | ||
26 | |||
27 | S = "${WORKDIR}/git" | ||
28 | |||
29 | COMPATIBLE_HOST = '(x86_64.*|i.86.*|arm.*|aarch64.*)-(linux.*|freebsd.*)' | ||
30 | |||
31 | inherit autotools | ||
32 | inherit gettext | ||
33 | |||
34 | PACKAGECONFIG ??= "" | ||
35 | PACKAGECONFIG[grub-mount] = "--enable-grub-mount,--disable-grub-mount,fuse" | ||
36 | |||
37 | # configure.ac has code to set this automagically from the target tuple | ||
38 | # but the OE freeform one (core2-foo-bar-linux) don't work with that. | ||
39 | |||
40 | GRUBPLATFORM_arm = "uboot" | ||
41 | GRUBPLATFORM_aarch64 = "efi" | ||
42 | GRUBPLATFORM ??= "pc" | ||
43 | |||
44 | EXTRA_OECONF = "--with-platform=${GRUBPLATFORM} --disable-grub-mkfont --program-prefix="" \ | ||
45 | --enable-liblzma=no --enable-device-mapper=no --enable-libzfs=no" | ||
46 | |||
47 | do_configure_prepend() { | ||
48 | ( cd ${S} | ||
49 | ${S}/autogen.sh ) | ||
50 | } | ||
51 | |||
52 | do_install_append () { | ||
53 | install -d ${D}${sysconfdir}/grub.d | ||
54 | install -m 0755 ${WORKDIR}/40_custom ${D}${sysconfdir}/grub.d/40_custom | ||
55 | } | ||
56 | |||
57 | RDEPENDS_${PN} = "diffutils freetype" | ||
58 | FILES_${PN}-dbg += "${libdir}/${BPN}/*/.debug" | ||
59 | |||
60 | INSANE_SKIP_${PN} = "arch" | ||
61 | INSANE_SKIP_${PN}-dbg = "arch" | ||