summaryrefslogtreecommitdiffstats
path: root/meta/recipes-bsp/grub/grub_git.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-bsp/grub/grub_git.bb')
-rw-r--r--meta/recipes-bsp/grub/grub_git.bb62
1 files changed, 62 insertions, 0 deletions
diff --git a/meta/recipes-bsp/grub/grub_git.bb b/meta/recipes-bsp/grub/grub_git.bb
new file mode 100644
index 0000000000..9b5d9bbd7d
--- /dev/null
+++ b/meta/recipes-bsp/grub/grub_git.bb
@@ -0,0 +1,62 @@
1SUMMARY = "GRUB2 is the next-generation GRand Unified Bootloader"
2
3DESCRIPTION = "GRUB2 is the next generaion of a GPLed bootloader \
4intended to unify bootloading across x86 operating systems. In \
5addition to loading the Linux kernel, it implements the Multiboot \
6standard, which allows for flexible loading of multiple boot images."
7
8HOMEPAGE = "http://www.gnu.org/software/grub/"
9SECTION = "bootloaders"
10
11LICENSE = "GPLv3"
12LIC_FILES_CHKSUM = "file://COPYING;md5=d32239bcb673463ab874e80d47fae504"
13
14DEPENDS = "autogen-native flex-native bison-native xz freetype"
15
16DEFAULT_PREFERENCE = "-1"
17DEFAULT_PREFERENCE_arm = "1"
18
19PV = "2.00+${SRCPV}"
20SRCREV = "0776112c5311196889a15058a3b1be4c81ba5e05"
21SRC_URI = "git://git.savannah.gnu.org/grub.git \
22 file://40_custom \
23 file://autogen.sh-exclude-pc.patch \
24 file://grub-2.00-add-oe-kernel.patch \
25 "
26
27S = "${WORKDIR}/git"
28
29COMPATIBLE_HOST = '(x86_64.*|i.86.*|arm.*|aarch64.*)-(linux.*|freebsd.*)'
30
31inherit autotools
32inherit gettext
33
34PACKAGECONFIG ??= ""
35PACKAGECONFIG[grub-mount] = "--enable-grub-mount,--disable-grub-mount,fuse"
36PACKAGECONFIG[device-mapper] = "--enable-device-mapper,--disable-device-mapper,lvm2"
37
38# configure.ac has code to set this automagically from the target tuple
39# but the OE freeform one (core2-foo-bar-linux) don't work with that.
40
41GRUBPLATFORM_arm = "uboot"
42GRUBPLATFORM_aarch64 = "efi"
43GRUBPLATFORM ??= "pc"
44
45EXTRA_OECONF = "--with-platform=${GRUBPLATFORM} --disable-grub-mkfont --program-prefix="" \
46 --enable-liblzma=no --enable-device-mapper=no --enable-libzfs=no"
47
48do_configure_prepend() {
49 ( cd ${S}
50 ${S}/autogen.sh )
51}
52
53do_install_append () {
54 install -d ${D}${sysconfdir}/grub.d
55 install -m 0755 ${WORKDIR}/40_custom ${D}${sysconfdir}/grub.d/40_custom
56}
57
58RDEPENDS_${PN} = "diffutils freetype"
59FILES_${PN}-dbg += "${libdir}/${BPN}/*/.debug"
60
61INSANE_SKIP_${PN} = "arch"
62INSANE_SKIP_${PN}-dbg = "arch"