summaryrefslogtreecommitdiffstats
path: root/meta/recipes-bsp/grub/grub_2.00.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-bsp/grub/grub_2.00.bb')
-rw-r--r--meta/recipes-bsp/grub/grub_2.00.bb52
1 files changed, 52 insertions, 0 deletions
diff --git a/meta/recipes-bsp/grub/grub_2.00.bb b/meta/recipes-bsp/grub/grub_2.00.bb
new file mode 100644
index 0000000000..c21031bde1
--- /dev/null
+++ b/meta/recipes-bsp/grub/grub_2.00.bb
@@ -0,0 +1,52 @@
1SUMMARY = "GRUB2 is the next-generation GRand Unified Bootloader"
2
3DESCRIPTION = "GRUB2 is the next generaion of a GPLed bootloader \
4intended to unify bootloading across x86 operating systems. In \
5addition to loading the Linux kernel, it implements the Multiboot \
6standard, which allows for flexible loading of multiple boot images."
7
8HOMEPAGE = "http://www.gnu.org/software/grub/"
9SECTION = "bootloaders"
10
11LICENSE = "GPLv3"
12LIC_FILES_CHKSUM = "file://COPYING;md5=d32239bcb673463ab874e80d47fae504"
13
14DEPENDS = "autogen-native flex-native bison-native xz"
15RDEPENDS_${PN} = "diffutils freetype"
16PR = "r1"
17
18SRC_URI = "ftp://ftp.gnu.org/gnu/grub/grub-${PV}.tar.gz \
19 file://grub-install.in.patch \
20 file://grub-2.00-fpmath-sse-387-fix.patch \
21 file://remove-gets.patch \
22 file://check-if-liblzma-is-disabled.patch \
23 file://40_custom \
24 file://fix-issue-with-flex-2.5.37.patch \
25 file://grub-2.00-add-oe-kernel.patch \
26 "
27
28SRC_URI[md5sum] = "e927540b6eda8b024fb0391eeaa4091c"
29SRC_URI[sha256sum] = "65b39a0558f8c802209c574f4d02ca263a804e8a564bc6caf1cd0fd3b3cc11e3"
30
31COMPATIBLE_HOST = '(x86_64.*|i.86.*)-(linux|freebsd.*)'
32
33FILES_${PN}-dbg += "${libdir}/${BPN}/i386-pc/.debug"
34
35
36inherit autotools
37inherit gettext
38
39PACKAGECONFIG ??= ""
40PACKAGECONFIG[grub-mount] = "--enable-grub-mount,--disable-grub-mount,fuse"
41PACKAGECONFIG[device-mapper] = "--enable-device-mapper,--disable-device-mapper,lvm2"
42
43EXTRA_OECONF = "--with-platform=pc --disable-grub-mkfont --program-prefix="" \
44 --enable-liblzma=no --enable-device-mapper=no --enable-libzfs=no"
45
46do_install_append () {
47 install -d ${D}${sysconfdir}/grub.d
48 install -m 0755 ${WORKDIR}/40_custom ${D}${sysconfdir}/grub.d/40_custom
49}
50
51INSANE_SKIP_${PN} = "arch"
52INSANE_SKIP_${PN}-dbg = "arch"