summaryrefslogtreecommitdiffstats
path: root/meta/recipes-bsp/grub/grub_2.00.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-bsp/grub/grub_2.00.bb')
-rw-r--r--meta/recipes-bsp/grub/grub_2.00.bb43
1 files changed, 43 insertions, 0 deletions
diff --git a/meta/recipes-bsp/grub/grub_2.00.bb b/meta/recipes-bsp/grub/grub_2.00.bb
new file mode 100644
index 0000000000..c88e095d7d
--- /dev/null
+++ b/meta/recipes-bsp/grub/grub_2.00.bb
@@ -0,0 +1,43 @@
1SUMMARY = "GRUB2 is the next-generation GRand Unified Bootloader"
2
3DESCRIPTION = "GRUB2 is the next generaion of a GPLed bootloader \
4intended to unify bootloading across x86 operating systems. In \
5addition to loading the Linux kernel, it implements the Multiboot \
6standard, which allows for flexible loading of multiple boot images."
7
8HOMEPAGE = "http://www.gnu.org/software/grub/"
9SECTION = "bootloaders"
10
11LICENSE = "GPLv3"
12LIC_FILES_CHKSUM = "file://COPYING;md5=d32239bcb673463ab874e80d47fae504"
13
14DEPENDS = "autogen-native flex-native"
15RDEPENDS_${PN} = "diffutils freetype"
16PR = "r0"
17
18SRC_URI = "ftp://ftp.gnu.org/gnu/grub/grub-${PV}.tar.gz \
19 file://grub-install.in.patch \
20 file://grub-1.99-fpmath-sse-387-fix.patch \
21 file://remove-gets.patch \
22 file://40_custom"
23
24SRC_URI[md5sum] = "e927540b6eda8b024fb0391eeaa4091c"
25SRC_URI[sha256sum] = "65b39a0558f8c802209c574f4d02ca263a804e8a564bc6caf1cd0fd3b3cc11e3"
26
27COMPATIBLE_HOST = '(x86_64.*|i.86.*)-(linux|freebsd.*)'
28
29FILES_${PN}-dbg += "${libdir}/${BPN}/i386-pc/.debug"
30
31
32inherit autotools
33inherit gettext
34
35EXTRA_OECONF = "--with-platform=pc --disable-grub-mkfont --program-prefix="""
36
37do_install_append () {
38 install -d ${D}${sysconfdir}/grub.d
39 install -m 0755 ${WORKDIR}/40_custom ${D}${sysconfdir}/grub.d/40_custom
40}
41
42INSANE_SKIP_${PN} = "arch"
43INSANE_SKIP_${PN}-dbg = "arch"