diff options
Diffstat (limited to 'meta/recipes-bsp/grub/grub_1.99.bb')
-rw-r--r-- | meta/recipes-bsp/grub/grub_1.99.bb | 44 |
1 files changed, 44 insertions, 0 deletions
diff --git a/meta/recipes-bsp/grub/grub_1.99.bb b/meta/recipes-bsp/grub/grub_1.99.bb new file mode 100644 index 0000000000..d9df573e25 --- /dev/null +++ b/meta/recipes-bsp/grub/grub_1.99.bb | |||
@@ -0,0 +1,44 @@ | |||
1 | SUMMARY = "GRUB2 is the next-generation GRand Unified Bootloader" | ||
2 | |||
3 | DESCRIPTION = "GRUB2 is the next generaion of a GPLed bootloader \ | ||
4 | intended to unify bootloading across x86 operating systems. In \ | ||
5 | addition to loading the Linux kernel, it implements the Multiboot \ | ||
6 | standard, which allows for flexible loading of multiple boot images." | ||
7 | |||
8 | HOMEPAGE = "http://www.gnu.org/software/grub/" | ||
9 | SECTION = "bootloaders" | ||
10 | PRIORITY = "optional" | ||
11 | |||
12 | LICENSE = "GPLv3" | ||
13 | LIC_FILES_CHKSUM = "file://COPYING;md5=d32239bcb673463ab874e80d47fae504" | ||
14 | |||
15 | RDEPENDS = "diffutils freetype" | ||
16 | PR = "r0" | ||
17 | |||
18 | SRC_URI = "ftp://ftp.gnu.org/gnu/grub/grub-${PV}.tar.gz \ | ||
19 | file://grub-install.in.patch;apply=yes \ | ||
20 | file://40_custom" | ||
21 | |||
22 | inherit autotools | ||
23 | inherit gettext | ||
24 | |||
25 | EXTRA_OECONF = "--with-platform=pc --disable-grub-mkfont --target=${TARGET_ARCH} --program-prefix=""" | ||
26 | |||
27 | do_configure() { | ||
28 | oe_runconf | ||
29 | } | ||
30 | |||
31 | python __anonymous () { | ||
32 | import re | ||
33 | host = bb.data.getVar('HOST_SYS', d, 1) | ||
34 | if not re.match('x86.64.*-linux', host) and not re.match('i.86.*-linux', host): | ||
35 | raise bb.parse.SkipPackage("incompatible with host %s" % host) | ||
36 | } | ||
37 | |||
38 | do_install_append () { | ||
39 | install -m 0755 ${WORKDIR}/40_custom ${D}${sysconfdir}/grub.d/40_custom | ||
40 | } | ||
41 | |||
42 | FILES_${PN}-doc = "${datadir}" | ||
43 | FILES_${PN} = "/usr /etc" | ||
44 | |||