summaryrefslogtreecommitdiffstats
path: root/meta/recipes-bsp/grub/grub_1.99.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-bsp/grub/grub_1.99.bb')
-rw-r--r--meta/recipes-bsp/grub/grub_1.99.bb44
1 files changed, 44 insertions, 0 deletions
diff --git a/meta/recipes-bsp/grub/grub_1.99.bb b/meta/recipes-bsp/grub/grub_1.99.bb
new file mode 100644
index 0000000000..d9df573e25
--- /dev/null
+++ b/meta/recipes-bsp/grub/grub_1.99.bb
@@ -0,0 +1,44 @@
1SUMMARY = "GRUB2 is the next-generation GRand Unified Bootloader"
2
3DESCRIPTION = "GRUB2 is the next generaion of a GPLed bootloader \
4intended to unify bootloading across x86 operating systems. In \
5addition to loading the Linux kernel, it implements the Multiboot \
6standard, which allows for flexible loading of multiple boot images."
7
8HOMEPAGE = "http://www.gnu.org/software/grub/"
9SECTION = "bootloaders"
10PRIORITY = "optional"
11
12LICENSE = "GPLv3"
13LIC_FILES_CHKSUM = "file://COPYING;md5=d32239bcb673463ab874e80d47fae504"
14
15RDEPENDS = "diffutils freetype"
16PR = "r0"
17
18SRC_URI = "ftp://ftp.gnu.org/gnu/grub/grub-${PV}.tar.gz \
19 file://grub-install.in.patch;apply=yes \
20 file://40_custom"
21
22inherit autotools
23inherit gettext
24
25EXTRA_OECONF = "--with-platform=pc --disable-grub-mkfont --target=${TARGET_ARCH} --program-prefix="""
26
27do_configure() {
28 oe_runconf
29}
30
31python __anonymous () {
32 import re
33 host = bb.data.getVar('HOST_SYS', d, 1)
34 if not re.match('x86.64.*-linux', host) and not re.match('i.86.*-linux', host):
35 raise bb.parse.SkipPackage("incompatible with host %s" % host)
36}
37
38do_install_append () {
39 install -m 0755 ${WORKDIR}/40_custom ${D}${sysconfdir}/grub.d/40_custom
40}
41
42FILES_${PN}-doc = "${datadir}"
43FILES_${PN} = "/usr /etc"
44