diff options
Diffstat (limited to 'meta/recipes-bsp/grub/grub_0.97.bb')
-rw-r--r-- | meta/recipes-bsp/grub/grub_0.97.bb | 31 |
1 files changed, 31 insertions, 0 deletions
diff --git a/meta/recipes-bsp/grub/grub_0.97.bb b/meta/recipes-bsp/grub/grub_0.97.bb new file mode 100644 index 0000000000..6b6b5b0c29 --- /dev/null +++ b/meta/recipes-bsp/grub/grub_0.97.bb | |||
@@ -0,0 +1,31 @@ | |||
1 | DESCRIPTION = "GRUB is the GRand Unified Bootloader." | ||
2 | HOMEPAGE = "http://www.gnu.org/software/grub/" | ||
3 | SECTION = "bootloaders" | ||
4 | PRIORITY = "optional" | ||
5 | |||
6 | LICENSE = "GPLv2+" | ||
7 | LIC_FILES_CHKSUM = "file://COPYING;md5=c93c0550bd3173f4504b2cbd8991e50b \ | ||
8 | file://grub/main.c;beginline=3;endline=9;md5=22a5f28d2130fff9f2a17ed54be90ed6" | ||
9 | |||
10 | RDEPENDS = "diffutils" | ||
11 | PR = "r2" | ||
12 | |||
13 | SRC_URI = "ftp://alpha.gnu.org/gnu/grub/grub-${PV}.tar.gz; \ | ||
14 | file://autohell.patch;apply=yes " | ||
15 | |||
16 | inherit autotools | ||
17 | |||
18 | python __anonymous () { | ||
19 | import re | ||
20 | host = bb.data.getVar('HOST_SYS', d, 1) | ||
21 | if not re.match('i.86.*-linux', host): | ||
22 | raise bb.parse.SkipPackage("incompatible with host %s" % host) | ||
23 | } | ||
24 | |||
25 | do_install_append_vmware() { | ||
26 | mkdir -p ${D}/boot/ | ||
27 | ln -sf ../usr/lib/grub/{$TARGET_ARCH}{$TARGET_VENDOR}/ ${D}/boot/grub | ||
28 | } | ||
29 | |||
30 | FILES_${PN}-doc = "${datadir}" | ||
31 | FILES_${PN} = "/boot /usr" | ||