summaryrefslogtreecommitdiffstats
path: root/meta/recipes-bsp/grub/grub-efi_2.04.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-bsp/grub/grub-efi_2.04.bb')
-rw-r--r--meta/recipes-bsp/grub/grub-efi_2.04.bb4
1 files changed, 4 insertions, 0 deletions
diff --git a/meta/recipes-bsp/grub/grub-efi_2.04.bb b/meta/recipes-bsp/grub/grub-efi_2.04.bb
index 30d95f95e0..f80afd95cb 100644
--- a/meta/recipes-bsp/grub/grub-efi_2.04.bb
+++ b/meta/recipes-bsp/grub/grub-efi_2.04.bb
@@ -26,6 +26,10 @@ python __anonymous () {
26 grubtarget = 'arm64' 26 grubtarget = 'arm64'
27 elif re.match('arm', target): 27 elif re.match('arm', target):
28 grubtarget = 'arm' 28 grubtarget = 'arm'
29 elif re.match('riscv64', target):
30 grubtarget = 'riscv64'
31 elif re.match('riscv32', target):
32 grubtarget = 'riscv32'
29 else: 33 else:
30 raise bb.parse.SkipRecipe("grub-efi is incompatible with target %s" % target) 34 raise bb.parse.SkipRecipe("grub-efi is incompatible with target %s" % target)
31 grubimage = prefix + d.getVar("EFI_BOOT_IMAGE") 35 grubimage = prefix + d.getVar("EFI_BOOT_IMAGE")