summaryrefslogtreecommitdiffstats
path: root/meta/recipes-bsp/grub/grub-efi_2.04.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-bsp/grub/grub-efi_2.04.bb')
-rw-r--r--meta/recipes-bsp/grub/grub-efi_2.04.bb28
1 files changed, 6 insertions, 22 deletions
diff --git a/meta/recipes-bsp/grub/grub-efi_2.04.bb b/meta/recipes-bsp/grub/grub-efi_2.04.bb
index b9d6225d27..30d95f95e0 100644
--- a/meta/recipes-bsp/grub/grub-efi_2.04.bb
+++ b/meta/recipes-bsp/grub/grub-efi_2.04.bb
@@ -4,8 +4,8 @@ require conf/image-uefi.conf
4 4
5GRUBPLATFORM = "efi" 5GRUBPLATFORM = "efi"
6 6
7DEPENDS_append_class-target = " grub-efi-native" 7DEPENDS_append = " grub-native"
8RDEPENDS_${PN}_class-target = "grub-common virtual/grub-bootconf" 8RDEPENDS_${PN} = "grub-common virtual/grub-bootconf"
9 9
10SRC_URI += " \ 10SRC_URI += " \
11 file://cfg \ 11 file://cfg \
@@ -51,22 +51,7 @@ do_mkimage() {
51 51
52addtask mkimage before do_install after do_compile 52addtask mkimage before do_install after do_compile
53 53
54do_mkimage_class-native() { 54do_install() {
55 :
56}
57
58do_install_append_class-target() {
59 install -d ${D}${EFI_FILES_PATH}
60 install -m 644 ${B}/${GRUB_IMAGE_PREFIX}${GRUB_IMAGE} ${D}${EFI_FILES_PATH}/${GRUB_IMAGE}
61}
62
63do_install_class-native() {
64 install -d ${D}${bindir}
65 install -m 755 grub-mkimage ${D}${bindir}
66 install -m 755 grub-editenv ${D}${bindir}
67}
68
69do_install_class-target() {
70 oe_runmake 'DESTDIR=${D}' -C grub-core install 55 oe_runmake 'DESTDIR=${D}' -C grub-core install
71 56
72 # Remove build host references... 57 # Remove build host references...
@@ -76,6 +61,9 @@ do_install_class-target() {
76 -e 's|${DEBUG_PREFIX_MAP}||g' \ 61 -e 's|${DEBUG_PREFIX_MAP}||g' \
77 -e 's:${RECIPE_SYSROOT_NATIVE}::g' \ 62 -e 's:${RECIPE_SYSROOT_NATIVE}::g' \
78 {} + 63 {} +
64
65 install -d ${D}${EFI_FILES_PATH}
66 install -m 644 ${B}/${GRUB_IMAGE_PREFIX}${GRUB_IMAGE} ${D}${EFI_FILES_PATH}/${GRUB_IMAGE}
79} 67}
80 68
81do_install_append_aarch64() { 69do_install_append_aarch64() {
@@ -89,10 +77,6 @@ do_deploy() {
89 install -m 644 ${B}/${GRUB_IMAGE_PREFIX}${GRUB_IMAGE} ${DEPLOYDIR} 77 install -m 644 ${B}/${GRUB_IMAGE_PREFIX}${GRUB_IMAGE} ${DEPLOYDIR}
90} 78}
91 79
92do_deploy_class-native() {
93 :
94}
95
96addtask deploy after do_install before do_build 80addtask deploy after do_install before do_build
97 81
98FILES_${PN} = "${libdir}/grub/${GRUB_TARGET}-efi \ 82FILES_${PN} = "${libdir}/grub/${GRUB_TARGET}-efi \