summaryrefslogtreecommitdiffstats
path: root/meta/recipes-bsp/grub/grub-efi_2.00.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-bsp/grub/grub-efi_2.00.bb')
-rw-r--r--meta/recipes-bsp/grub/grub-efi_2.00.bb48
1 files changed, 11 insertions, 37 deletions
diff --git a/meta/recipes-bsp/grub/grub-efi_2.00.bb b/meta/recipes-bsp/grub/grub-efi_2.00.bb
index d213f31a20..a337d3d4cb 100644
--- a/meta/recipes-bsp/grub/grub-efi_2.00.bb
+++ b/meta/recipes-bsp/grub/grub-efi_2.00.bb
@@ -1,39 +1,12 @@
1SUMMARY = "GRUB2 is the next-generation GRand Unified Bootloader" 1require grub2.inc
2 2
3DESCRIPTION = "GRUB2 is the next generaion of a GPLed bootloader \
4intended to unify bootloading across x86 operating systems. In \
5addition to loading the Linux kernel, it implements the Multiboot \
6standard, which allows for flexible loading of multiple boot images. \
7This recipe builds an EFI binary for the target. It does not install \
8or package anything, it only deploys a target-arch GRUB EFI image."
9
10HOMEPAGE = "http://www.gnu.org/software/grub/"
11SECTION = "bootloaders"
12
13LICENSE = "GPLv3"
14LIC_FILES_CHKSUM = "file://COPYING;md5=d32239bcb673463ab874e80d47fae504"
15
16# FIXME: We should be able to optionally drop freetype as a dependency
17DEPENDS = "autogen-native flex-native bison-native"
18DEPENDS_class-target = "grub-efi-native" 3DEPENDS_class-target = "grub-efi-native"
4RDEPENDS_${PN}_class-target = "diffutils freetype"
19PR = "r2" 5PR = "r2"
20 6
21SRC_URI = "ftp://ftp.gnu.org/gnu/grub/grub-${PV}.tar.gz \ 7SRC_URI += " \
22 file://cfg \ 8 file://cfg \
23 file://grub-2.00-fpmath-sse-387-fix.patch \
24 file://grub-2.00-fix-enable_execute_stack-check.patch \
25 file://check-if-liblzma-is-disabled.patch \
26 file://grub-no-unused-result.patch \
27 file://grub-2.00-ignore-gnulib-gets-stupidity.patch \
28 file://fix-issue-with-flex-2.5.37.patch \
29 file://grub-efi-allow-a-compilation-without-mcmodel-large.patch \
30 file://grub-2.00-add-oe-kernel.patch \
31 file://grub-efi-fix-with-glibc-2.20.patch \
32 " 9 "
33SRC_URI[md5sum] = "e927540b6eda8b024fb0391eeaa4091c"
34SRC_URI[sha256sum] = "65b39a0558f8c802209c574f4d02ca263a804e8a564bc6caf1cd0fd3b3cc11e3"
35
36COMPATIBLE_HOST = '(x86_64.*|i.86.*)-(linux|freebsd.*)'
37 10
38S = "${WORKDIR}/grub-${PV}" 11S = "${WORKDIR}/grub-${PV}"
39 12
@@ -53,17 +26,13 @@ python __anonymous () {
53 d.setVar("GRUB_IMAGE", grubimage) 26 d.setVar("GRUB_IMAGE", grubimage)
54} 27}
55 28
56inherit autotools-brokensep gettext texinfo deploy 29inherit deploy
57 30
58CACHED_CONFIGUREVARS += "ac_cv_path_HELP2MAN=" 31CACHED_CONFIGUREVARS += "ac_cv_path_HELP2MAN="
59EXTRA_OECONF = "--with-platform=efi --disable-grub-mkfont \ 32EXTRA_OECONF = "--with-platform=efi --disable-grub-mkfont \
60 --enable-efiemu=no --program-prefix='' \ 33 --enable-efiemu=no --program-prefix='' \
61 --enable-liblzma=no --enable-device-mapper=no --enable-libzfs=no" 34 --enable-liblzma=no --enable-device-mapper=no --enable-libzfs=no"
62 35
63do_install_class-target() {
64 :
65}
66
67do_install_class-native() { 36do_install_class-native() {
68 install -d ${D}${bindir} 37 install -d ${D}${bindir}
69 install -m 755 grub-mkimage ${D}${bindir} 38 install -m 755 grub-mkimage ${D}${bindir}
@@ -86,7 +55,12 @@ do_deploy_class-native() {
86 55
87addtask deploy after do_install before do_build 56addtask deploy after do_install before do_build
88 57
89FILES_${PN}-dbg += "${libdir}/${BPN}/${GRUB_TARGET}-efi/.debug" 58FILES_${PN}-dbg += "${libdir}/grub/${GRUB_TARGET}-efi/.debug \
59 /boot/efi/EFI/BOOT/${GRUB_TARGET}-efi/.debug \
60 "
61FILES_${PN} += "${libdir}/grub/${GRUB_TARGET}-efi \
62 ${datadir}/grub \
63 "
90 64
91BBCLASSEXTEND = "native" 65BBCLASSEXTEND = "native"
92ALLOW_EMPTY_${PN} = "1" 66