diff options
Diffstat (limited to 'meta/recipes-bsp/gnu-efi/gnu-efi_3.0u.bb')
-rw-r--r-- | meta/recipes-bsp/gnu-efi/gnu-efi_3.0u.bb | 33 |
1 files changed, 33 insertions, 0 deletions
diff --git a/meta/recipes-bsp/gnu-efi/gnu-efi_3.0u.bb b/meta/recipes-bsp/gnu-efi/gnu-efi_3.0u.bb new file mode 100644 index 0000000000..0dbdba27ac --- /dev/null +++ b/meta/recipes-bsp/gnu-efi/gnu-efi_3.0u.bb | |||
@@ -0,0 +1,33 @@ | |||
1 | SUMMARY = "Libraries for producing EFI binaries" | ||
2 | HOMEPAGE = "http://sourceforge.net/projects/gnu-efi/" | ||
3 | SECTION = "devel" | ||
4 | LICENSE = "GPLv2+" | ||
5 | LIC_FILES_CHKSUM = "file://debian/copyright;md5=5fb358a180f484b285b0d99acdc29666" | ||
6 | |||
7 | SRC_URI = "http://downloads.sourceforge.net/gnu-efi/gnu-efi_3.0u.orig.tar.gz \ | ||
8 | file://parallel-make.patch \ | ||
9 | file://parallel-make-archives.patch \ | ||
10 | " | ||
11 | SRC_URI[md5sum] = "d15d3c700e79a1e2938544d73edc572d" | ||
12 | SRC_URI[sha256sum] = "3c0d450d5829204ca05dcb3b2aae772e52c379b7c7e09146759c6315606f934e" | ||
13 | |||
14 | COMPATIBLE_HOST = "(x86_64.*|i.86.*)-linux" | ||
15 | |||
16 | S = "${WORKDIR}/gnu-efi-3.0" | ||
17 | |||
18 | def gnu_efi_arch(d): | ||
19 | import re | ||
20 | tarch = d.getVar("TARGET_ARCH", True) | ||
21 | if re.match("i[3456789]86", tarch): | ||
22 | return "ia32" | ||
23 | return tarch | ||
24 | |||
25 | EXTRA_OEMAKE = "'ARCH=${@gnu_efi_arch(d)}' 'CC=${CC}' 'AS=${AS}' 'LD=${LD}' 'AR=${AR}' \ | ||
26 | 'RANLIB=${RANLIB}' 'OBJCOPY=${OBJCOPY}' 'PREFIX=${prefix}'\ | ||
27 | " | ||
28 | |||
29 | do_install() { | ||
30 | oe_runmake install INSTALLROOT="${D}" | ||
31 | } | ||
32 | |||
33 | FILES_${PN} += "${libdir}/*.lds" | ||