summaryrefslogtreecommitdiffstats
path: root/meta/recipes-bsp/formfactor/formfactor_0.0.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-bsp/formfactor/formfactor_0.0.bb')
-rw-r--r--meta/recipes-bsp/formfactor/formfactor_0.0.bb21
1 files changed, 21 insertions, 0 deletions
diff --git a/meta/recipes-bsp/formfactor/formfactor_0.0.bb b/meta/recipes-bsp/formfactor/formfactor_0.0.bb
new file mode 100644
index 0000000000..5c30bd510d
--- /dev/null
+++ b/meta/recipes-bsp/formfactor/formfactor_0.0.bb
@@ -0,0 +1,21 @@
1SUMMARY = "Device formfactor information"
2SECTION = "base"
3LICENSE = "MIT"
4LIC_FILES_CHKSUM = "file://${COREBASE}/LICENSE;md5=4d92cd373abda3937c2bc47fbc49d690 \
5 file://${COREBASE}/meta/COPYING.MIT;md5=3da9cfbcb788c80a0384361b4de20420"
6PR = "r45"
7
8SRC_URI = "file://config file://machconfig"
9S = "${WORKDIR}"
10
11PACKAGE_ARCH = "${MACHINE_ARCH}"
12INHIBIT_DEFAULT_DEPS = "1"
13
14do_install() {
15 # Install file only if it has contents
16 install -d ${D}${sysconfdir}/formfactor/
17 install -m 0644 ${S}/config ${D}${sysconfdir}/formfactor/
18 if [ -s "${S}/machconfig" ]; then
19 install -m 0644 ${S}/machconfig ${D}${sysconfdir}/formfactor/
20 fi
21}