summaryrefslogtreecommitdiffstats
path: root/meta/recipes-bsp/formfactor/formfactor_0.0.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-bsp/formfactor/formfactor_0.0.bb')
-rw-r--r--meta/recipes-bsp/formfactor/formfactor_0.0.bb18
1 files changed, 18 insertions, 0 deletions
diff --git a/meta/recipes-bsp/formfactor/formfactor_0.0.bb b/meta/recipes-bsp/formfactor/formfactor_0.0.bb
new file mode 100644
index 0000000000..bee1b380aa
--- /dev/null
+++ b/meta/recipes-bsp/formfactor/formfactor_0.0.bb
@@ -0,0 +1,18 @@
1DESCRIPTION = "Device formfactor information"
2SECTION = "base"
3LICENSE = "MIT"
4PR = "r18"
5
6SRC_URI = "file://config file://machconfig"
7S = "${WORKDIR}"
8
9PACKAGE_ARCH = "${MACHINE_ARCH}"
10
11do_install() {
12 # Only install file if it has a contents
13 install -d ${D}${sysconfdir}/formfactor/
14 install -m 0644 ${S}/config ${D}${sysconfdir}/formfactor/
15 if [ -s "${S}/machconfig" ]; then
16 install -m 0644 ${S}/machconfig ${D}${sysconfdir}/formfactor/
17 fi
18}