summaryrefslogtreecommitdiffstats
path: root/meta/recipes-bsp/alsa-state/alsa-state.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-bsp/alsa-state/alsa-state.bb')
-rw-r--r--meta/recipes-bsp/alsa-state/alsa-state.bb65
1 files changed, 65 insertions, 0 deletions
diff --git a/meta/recipes-bsp/alsa-state/alsa-state.bb b/meta/recipes-bsp/alsa-state/alsa-state.bb
new file mode 100644
index 0000000000..17c2d002d5
--- /dev/null
+++ b/meta/recipes-bsp/alsa-state/alsa-state.bb
@@ -0,0 +1,65 @@
1# Copyright Matthias Hentges <devel@hentges.net> (c) 2007
2# License: MIT (see http://www.opensource.org/licenses/mit-license.php
3# for a copy of the license)
4#
5# Filename: alsa-state.bb
6
7SUMMARY = "Alsa scenario files to enable alsa state restoration"
8DESCRIPTION = "Alsa Scenario Files - an init script and state files to restore \
9sound state at system boot and save it at system shut down."
10LICENSE = "MIT"
11LIC_FILES_CHKSUM = "file://${COREBASE}/meta/COPYING.MIT;md5=3da9cfbcb788c80a0384361b4de20420"
12PV = "0.2.0"
13PR = "r5"
14
15SRC_URI = "\
16 file://asound.conf \
17 file://asound.state \
18 file://alsa-state-init \
19"
20
21# As the recipe doesn't inherit systemd.bbclass, we need to set this variable
22# manually to avoid unnecessary postinst/preinst generated.
23python __anonymous() {
24 if not bb.utils.contains('DISTRO_FEATURES', 'sysvinit', True, False, d):
25 d.setVar("INHIBIT_UPDATERCD_BBCLASS", "1")
26}
27
28inherit update-rc.d
29
30INITSCRIPT_NAME = "alsa-state"
31INITSCRIPT_PARAMS = "start 39 S . stop 31 0 6 ."
32
33do_install() {
34 # Only install the init script when 'sysvinit' is in DISTRO_FEATURES.
35 if ${@bb.utils.contains('DISTRO_FEATURES','sysvinit','true','false',d)}; then
36 sed -i -e "s:#STATEDIR#:${localstatedir}/lib/alsa:g" ${WORKDIR}/alsa-state-init
37 install -d ${D}${sysconfdir}/init.d
38 install -m 0755 ${WORKDIR}/alsa-state-init ${D}${sysconfdir}/init.d/alsa-state
39 fi
40
41 install -d ${D}/${localstatedir}/lib/alsa
42 install -d ${D}${sysconfdir}
43 install -m 0644 ${WORKDIR}/asound.conf ${D}${sysconfdir}
44 install -m 0644 ${WORKDIR}/*.state ${D}${localstatedir}/lib/alsa
45}
46
47PACKAGES += "alsa-states"
48
49RRECOMMENDS_alsa-state = "alsa-states"
50
51RDEPENDS_${PN} = "alsa-utils-alsactl"
52FILES_${PN} = "${sysconfdir}/init.d ${sysconfdir}/asound.conf"
53CONFFILES_${PN} = "${sysconfdir}/asound.conf"
54
55FILES_alsa-states = "${localstatedir}/lib/alsa/*.state"
56
57pkg_postinst_${PN}() {
58 if test -z "$D"
59 then
60 if test -x ${sbindir}/alsactl
61 then
62 ${sbindir}/alsactl -f ${localstatedir}/lib/alsa/asound.state restore
63 fi
64 fi
65}