summaryrefslogtreecommitdiffstats
path: root/meta/recipes-benchmark/bonnie++/bonnie++_1.03e.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-benchmark/bonnie++/bonnie++_1.03e.bb')
-rw-r--r--meta/recipes-benchmark/bonnie++/bonnie++_1.03e.bb30
1 files changed, 30 insertions, 0 deletions
diff --git a/meta/recipes-benchmark/bonnie++/bonnie++_1.03e.bb b/meta/recipes-benchmark/bonnie++/bonnie++_1.03e.bb
new file mode 100644
index 0000000000..8a15add505
--- /dev/null
+++ b/meta/recipes-benchmark/bonnie++/bonnie++_1.03e.bb
@@ -0,0 +1,30 @@
1DESCRIPTION = "Tests large file IO and creation/deletion of small files."
2HOMEPAGE = "http://www.coker.com.au/bonnie++/"
3LICENSE = "GPLv2"
4LIC_FILES_CHKSUM = "file://copyright.txt;md5=cd4dde95a6b9d122f0a9150ae9cc3ee0"
5
6SRC_URI = "http://www.coker.com.au/bonnie++/bonnie++-${PV}.tgz \
7 file://bonnie++_avoid_build_err.patch \
8 "
9
10SRC_URI[md5sum] = "750aa5b5051263a99c6c195888c74968"
11SRC_URI[sha256sum] = "cb3866116634bf65760b6806be4afa7e24a1cad6f145c876df8721f01ba2e2cb"
12
13inherit autotools autotools-brokensep
14
15SCRIPTS = "bon_csv2html bon_csv2txt"
16EXES = "bonnie++ zcav"
17
18TARGET_CC_ARCH += "${LDFLAGS}"
19
20do_install () {
21 install -d ${D}/usr/bin
22 install -d ${D}/usr/sbin
23 install -m 0755 ${EXES} ${D}/usr/sbin
24 install -m 0755 ${SCRIPTS} ${D}/usr/bin
25}
26
27PACKAGES =+ "bonnie-scripts"
28
29FILES_${PN} = "${sbindir}"
30FILES_bonnie-scripts = "${bindir}"