summaryrefslogtreecommitdiffstats
path: root/meta/packages/zip/zip_2.31.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/packages/zip/zip_2.31.bb')
-rw-r--r--meta/packages/zip/zip_2.31.bb17
1 files changed, 17 insertions, 0 deletions
diff --git a/meta/packages/zip/zip_2.31.bb b/meta/packages/zip/zip_2.31.bb
new file mode 100644
index 0000000000..6c588a55e5
--- /dev/null
+++ b/meta/packages/zip/zip_2.31.bb
@@ -0,0 +1,17 @@
1SECTION = "console/utils"
2SRC_URI = "http://ftp.info-zip.org/pub/infozip/src/zip231.tar.gz"
3LICENSE = "Info-ZIP"
4EXTRA_OEMAKE = "'CC=${CC}' 'BIND=${CC}' 'AS=${CC} -c' 'CPP=${CPP}' \
5 'CFLAGS=-I. -DUNIX ${CFLAGS}' 'INSTALL=install' \
6 'BINFLAGS=0755' 'INSTALL_D=install -d'"
7
8do_compile() {
9 oe_runmake -f unix/Makefile generic
10}
11
12do_install() {
13 oe_runmake -f unix/Makefile prefix=${D}${prefix} \
14 BINDIR=${D}${bindir} MANDIR=${D}${mandir}/man1 \
15 install
16}
17