summaryrefslogtreecommitdiffstats
path: root/meta/packages/zaurus-updater/zaurus-updater.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/packages/zaurus-updater/zaurus-updater.bb')
-rw-r--r--meta/packages/zaurus-updater/zaurus-updater.bb31
1 files changed, 31 insertions, 0 deletions
diff --git a/meta/packages/zaurus-updater/zaurus-updater.bb b/meta/packages/zaurus-updater/zaurus-updater.bb
new file mode 100644
index 0000000000..26cf1e5453
--- /dev/null
+++ b/meta/packages/zaurus-updater/zaurus-updater.bb
@@ -0,0 +1,31 @@
1DESCRIPTION = "Encrypted shellscript for the Zaurus ROM update"
2DEPENDS = "encdec-updater-native"
3LICENSE = "zaurus-updater"
4PR = "r5"
5
6PACKAGES = ""
7PACKAGE_ARCH = "${MACHINE_ARCH}"
8COMPATIBLE_MACHINE = '(poodle|c7x0|spitz|akita|tosa)'
9
10SRC_URI = "file://updater.sh \
11 file://gnu-tar.gz"
12S = "${WORKDIR}"
13
14do_compile() {
15 encdec-updater -e updater.sh
16}
17
18do_deploy() {
19 install -d ${DEPLOY_DIR_IMAGE}
20 install -m 0755 updater.sh ${DEPLOY_DIR_IMAGE}/updater.sh.${MACHINE}
21
22 case ${MACHINE} in
23 spitz )
24 install -m 0755 gnu-tar ${DEPLOY_DIR_IMAGE}/gnu-tar
25 ;;
26 *)
27 ;;
28 esac
29}
30
31addtask deploy before do_build after do_compile