diff options
Diffstat (limited to 'meta/packages/yum/yum_3.2.27.bb')
-rw-r--r-- | meta/packages/yum/yum_3.2.27.bb | 43 |
1 files changed, 43 insertions, 0 deletions
diff --git a/meta/packages/yum/yum_3.2.27.bb b/meta/packages/yum/yum_3.2.27.bb new file mode 100644 index 0000000000..e51aacd562 --- /dev/null +++ b/meta/packages/yum/yum_3.2.27.bb | |||
@@ -0,0 +1,43 @@ | |||
1 | HOMEPAGE = "http://linux.duke.edu/projects/yum/" | ||
2 | PR = "r7" | ||
3 | |||
4 | SRC_URI = "http://linux.duke.edu/projects/yum/download/3.2/yum-${PV}.tar.gz \ | ||
5 | file://paths.patch;patch=1 \ | ||
6 | file://paths2.patch;patch=1 \ | ||
7 | file://yum-install-recommends.py \ | ||
8 | file://extract-postinst.awk \ | ||
9 | file://98_yum" | ||
10 | |||
11 | RDEPENDS = "python-rpm python-core python-iniparse python-urlgrabber \ | ||
12 | python-shell python-re python-logging python-pickle \ | ||
13 | python-netserver python-compression \ | ||
14 | python-unixadmin python-xml python-sqlite3 \ | ||
15 | python-textutils python-fcntl python-email \ | ||
16 | yum-metadata-parser" | ||
17 | |||
18 | S = "${WORKDIR}/yum-${PV}" | ||
19 | |||
20 | inherit autotools | ||
21 | |||
22 | do_compile_append () { | ||
23 | sed -e 's#!/usr/bin/python#!${bindir}/python#' -e 's#/usr/share#${datadir}#' -i ${S}/bin/yum.py | ||
24 | sed -e 's#!/usr/bin/python#!${bindir}/python#' -e 's#/usr/share#${datadir}#' -i ${S}/bin/yum-updatesd.py | ||
25 | } | ||
26 | |||
27 | do_install_append () { | ||
28 | install -d ${D}${bindir}/ | ||
29 | install ${WORKDIR}/extract-postinst.awk ${D}${bindir}/ | ||
30 | install ${WORKDIR}/yum-install-recommends.py ${D}${bindir}/ | ||
31 | rmdir ${D}${localstatedir}/cache/yum | ||
32 | rmdir ${D}${localstatedir}/cache | ||
33 | install -d ${D}/etc/default/volatiles | ||
34 | install -m 0644 ${WORKDIR}/98_yum ${D}/etc/default/volatiles | ||
35 | } | ||
36 | |||
37 | pkg_postinst_yum () { | ||
38 | /etc/init.d/populate-volatile.sh update | ||
39 | } | ||
40 | |||
41 | FILES_${PN} += "${libdir}/python* ${datadir}/yum-cli" | ||
42 | |||
43 | BBCLASSEXTEND = "native" \ No newline at end of file | ||