summaryrefslogtreecommitdiffstats
path: root/meta/packages/yum/files/paths2.patch
diff options
context:
space:
mode:
Diffstat (limited to 'meta/packages/yum/files/paths2.patch')
-rw-r--r--meta/packages/yum/files/paths2.patch33
1 files changed, 33 insertions, 0 deletions
diff --git a/meta/packages/yum/files/paths2.patch b/meta/packages/yum/files/paths2.patch
new file mode 100644
index 0000000000..08c9c8312e
--- /dev/null
+++ b/meta/packages/yum/files/paths2.patch
@@ -0,0 +1,33 @@
1---
2 rpmUtils/Makefile | 2 +-
3 yum/Makefile | 2 +-
4 2 files changed, 2 insertions(+), 2 deletions(-)
5
6--- yum-3.2.18.orig/rpmUtils/Makefile
7+++ yum-3.2.18/rpmUtils/Makefile
8@@ -1,10 +1,10 @@
9 PYTHON=python
10 PACKAGE = $(shell basename `pwd`)
11 PYFILES = $(wildcard *.py)
12 PYVER := $(shell $(PYTHON) -c 'import sys; print "%.3s" %(sys.version)')
13-PYSYSDIR := $(shell $(PYTHON) -c 'import sys; print sys.prefix')
14+PYSYSDIR = /usr
15 PYLIBDIR = $(PYSYSDIR)/lib/python$(PYVER)
16 PKGDIR = $(PYLIBDIR)/site-packages/$(PACKAGE)
17
18 all:
19 echo "Nothing to do"
20--- yum-3.2.18.orig/yum/Makefile
21+++ yum-3.2.18/yum/Makefile
22@@ -1,10 +1,10 @@
23 PYTHON=python
24 PACKAGE = $(shell basename `pwd`)
25 PYFILES = $(wildcard *.py)
26 PYVER := $(shell $(PYTHON) -c 'import sys; print "%.3s" %(sys.version)')
27-PYSYSDIR := $(shell $(PYTHON) -c 'import sys; print sys.prefix')
28+PYSYSDIR = /usr
29 PYLIBDIR = $(PYSYSDIR)/lib/python$(PYVER)
30 PKGDIR = $(PYLIBDIR)/site-packages/$(PACKAGE)
31
32 all:
33 echo "Nothing to do"